# Table of Contents

Table of Contents .......................................................................................................................... 2

The Guide to the Microsoft Office Visio 2010 Tips & Techniques Documentation ......................... 9

**VISIO CORE FUNCTIONALITY & FEATURES** ............................................................................ 9

## KEYBOARD SHORTCUTS .......................................................................................................... 9

### NAVIGATION TIPS .................................................................................................................. 9

- Keyboard Navigation .................................................................................................................... 9
- Mouse-Based Navigation .............................................................................................................. 10
- Pan & Zoom Window .................................................................................................................. 10
- Window Scroll Bars ...................................................................................................................... 11
- Zoom Percentage Drop-Down List ............................................................................................... 11
- Best Practices .............................................................................................................................. 12

## CONNECTING Visio SmartShape Symbols .............................................................................. 12

### HOW TO CONNECT SmartShape symbols WITH THE NEW 2010 AUTOCONNECT FEATURE ........ 12

- Step One: .................................................................................................................................. 12
- Step Two: .................................................................................................................................. 12

### HOW TO CONNECT SmartShape symbols WITH THE 2007 AUTOCONNECT FEATURE ........... 12

- Step One: .................................................................................................................................. 12
- Step Two: .................................................................................................................................. 12
- Step Three: .................................................................................................................................. 13

### HOW TO CONNECT SmartShape symbols with POINT-TO-POINT GLUE AND DYNAMIC GLUE .... 13

- Point-to-Point Glue ..................................................................................................................... 13
- Dynamic (or Shape-to-Shape) Glue ............................................................................................... 14


### DYNAMIC CONNECTOR BEHAVIORS AND MANIPULATION ................................................ 15

- Adding and “bending” Leg Segments .......................................................................................... 15
- Changing Dynamic Connectors between Right-Angle, Straight, and Curved mode .................... 16

### ADDING, RELOCATING, DELETING AND CHANGING THE BEHAVIOUR OF CONNECTION POINTS ON SmartShape symbols ........................................................................ 16

- Adding Connection Points .......................................................................................................... 16
- Relocating Connection Points ..................................................................................................... 17
- Deleting Connection Points ......................................................................................................... 17

## 2D TO 2D GLUE ....................................................................................................................... 17
TIMELINE DIAGRAMS ........................................................................................................................................30
  ADDING A TOP-LEVEL TIMELINE ................................................................................................................30
  ADDING MILESTONES TO TIMELINES ........................................................................................................30
  ADDING INTERVALS TO TIMELINES ..............................................................................................................31
  ADDING TODAY MARKERS TO TIMELINES ....................................................................................................31
  ADDING ELAPSED TIME INDICATORS TO TIMELINES ..............................................................................31
  CREATING EXPANDED TIMELINES .............................................................................................................31
  EXPORTING MILESTONES AND INTERVALS TO MICROSOFT OFFICE PROJECT 2007 or PROJECT 2010 ....32
  IMPORTING MILESTONES AND INTERVALS FROM MICROSOFT OFFICE PROJECT 2007 or PROJECT 2010 ....32
BRAINSTORMING DIAGRAMS ...........................................................................................................................33
  CREATING BRAINSTORMING DIAGRAM HEIRARCHIES ..........................................................................33
  ADDING A SUBTOPIC .....................................................................................................................................33
  ADDING MULTIPLE SUBTOPICS ..................................................................................................................33
  RESTRUCTURING TOPICS AND SUBTOPICS ..............................................................................................34
  APPLYING BRAINSTORMING STYLES TO DIAGRAMS ..............................................................................34
  APPLYING BRAINSTORMING LAYOUTS TO DIAGRAMS ............................................................................34
  EXPORTING BRAINSTORMING DATA TO MICROSOFT OFFICE WORD 2007 or 2010 .......................35
  EXPORTING BRAINSTORMING DATA TO MICROSOFT OFFICE EXCEL 2007 or 2010 .........................35
  EXPORTING BRAINSTORMING DATA TO XML ...........................................................................................35
  IMPORTING BRAINSTORMING DATA FROM MICROSOFT OFFICE WORD 2007 or 2010 .....................36
ORGANIZATIONAL DIAGRAMS ........................................................................................................................37
  MANUALLY CREATING AN ORGANIZATIONAL [HIERARCHICAL] DIAGRAM ...........................................37
    Getting Started Methodology (Visio 2007) .................................................................................................37
    Getting Started Methodology (Visio 2010) .................................................................................................37
    File Menu Methodology (Visio 2007) .........................................................................................................37
    Adding the Executive ..................................................................................................................................37
  ADDING SUBORDINATES ..............................................................................................................................38
    Adding One Subordinate at a Time ...............................................................................................................38
    Adding Three Subordinates at the Same Time ............................................................................................39
    Adding Multiple Subordinates at the Same Time ......................................................................................39
    Adding Staff Members ...............................................................................................................................39
  ADDING TEAM FRAMES ..............................................................................................................................39
  ADDING “DOTTED-LINE” RELATIONSHIPS ...............................................................................................40
  CREATING SYNCHRONISED COPIES TO ADDITIONAL PAGES ............................................................40
  UNDERSTANDING SYNCHRONIZED COPIES .............................................................................................41
Expanding Subordinates .................................................................................................................. 41
Collapsing Subordinates .................................................................................................................. 41
Adding Divider Lines in Organizational SmartShape Symbols ......................................................... 41

CREATING HYPERLINKS BETWEEN PAGES AND SmartShape symbols ........................................... 41

USING THE ORGANIZATIONAL CHART WIZARD TO CREATE DIAGRAMS FROM EXCEL DATA ............. 42

Getting Started Methodology (Visio 2007) ..................................................................................... 42
Getting Started Methodology (Visio 2010) ..................................................................................... 42
File Menu Methodology (Visio 2007) ............................................................................................... 43
The Wizard ....................................................................................................................................... 43
From Data Stored in an External Data Source .................................................................................. 43
From Data Manually Entered in the Wizard ................................................................................. 43
Data Sources .................................................................................................................................... 44
Locating the data file ....................................................................................................................... 45
Specifying the language .................................................................................................................. 46
Data Fields ....................................................................................................................................... 46
Displayed Fields ........................................................................................................................... 46
Shape Data Fields ........................................................................................................................... 47
Breaking Down the Organization by Hierarchy ................................................................................ 47
Hyperlinks ........................................................................................................................................ 48
Synchronization ............................................................................................................................... 48

TRICKS FOR GLOBAL APPLICATION OF BACKGROUNDS TO ORGANIZATIONAL CHARTS ................. 48

EDITING CONTENT ON THE FACE OF ORGANIZATIONAL DIAGRAM SmartShape symbols ............ 49

EDITING THE SIZE OF ORGANIZATIONAL DIAGRAM SmartShape Symbols .................................... 51

ADDING PHOTOGRAPHS TO ORGANIZATIONAL DIAGRAM SmartShape symbols ............................. 51

OTHER NOTABLE CORE (STANDARD EDITION) DIAGRAM TYPES ......................................................... 51

VISIO ADVANCED FUNCTIONALITY & FEATURES ............................................................................ 52

TEXT FIELDS ..................................................................................................................................... 52

CUSTOM REPORTS .......................................................................................................................... 53

CUSTOM DESIGNED CUSTOM REPORTS ....................................................................................... 53
RUNNING CUSTOM REPORTS AND OUTPUT TARGETS ...................................................................... 54

DATABASE CONNECTIVITY .............................................................................................................. 54

THE DATABASE WIZARD [ Visio 2007 AND PRIOR ] .......................................................................... 54
THE NEW VISIO 2007 / 2010 DATABASE CONNECTIVITY WIZARD .................................................. 56
THE NEW VISIO 2007 / 2010 AUTOMATICALLY LINK WIZARD ........................................................ 57
THE NEW VISIO 2007 / 2010 DATA CONNECTIVITY DATA REFRESH WIZARD .................................... 57

Menu Shortcuts................................................................. 65

File ................................................................. 65

Edit ................................................................. 65

View ................................................................. 66

Insert ................................................................. 67

Format ................................................................. 67

Tools ................................................................. 68

Data ................................................................. 69

Shape ................................................................. 69

Window ................................................................. 70

Help ................................................................. 70
SmartShape Symbol Context (Right-Click) Menu Shortcuts ................................................. 71
Drawing Navigation Shortcuts ............................................................................................... 72
Drawing and Selection Tools Shortcuts .................................................................................. 72
Text Formatting Shortcuts ...................................................................................................... 72
Text Editing Keyboard Shortcuts ............................................................................................ 73
Shape Management Keyboard Shortcuts ................................................................................. 73

Appendix 2 – The Complete Visio 2007 Professional Edition Toolbars ............................... 75
The Toolbar Collection ............................................................................................................. 75
  Standard ............................................................................................................................... 75
  Formatting ............................................................................................................................ 75
  Action ................................................................................................................................. 75
  Data ..................................................................................................................................... 75
  Developer ............................................................................................................................. 76
  Drawing ............................................................................................................................... 76
  Format Shape ....................................................................................................................... 76
  Format Text .......................................................................................................................... 76
  Ink ........................................................................................................................................ 76
  Layout & Routing .................................................................................................................. 76
  Picture ................................................................................................................................. 77
  Reviewing ........................................................................................................................... 77
  Snap & Glue ......................................................................................................................... 77
  Stencil ................................................................................................................................. 77
  Task Pane ............................................................................................................................ 77
  View .................................................................................................................................... 78
  Web ...................................................................................................................................... 78

The Ribbon Tab Collection ...................................................................................................... 79
  File ....................................................................................................................................... 79
  Home .................................................................................................................................... 79
  Insert .................................................................................................................................... 79
  Design .................................................................................................................................. 80
  Data ...................................................................................................................................... 80
  Process ................................................................................................................................. 80
  Review ................................................................................................................................. 80
Appendix 4 – The Complete Visio 2007 / 2010 File Type Compendium

The Differences and Similarities between the VSD, VST, and VSS File Formats

The Catalog of Visio File Formats
The Guide to the Microsoft Office Visio 2010 Tips & Techniques Documentation

VISIO CORE FUNCTIONALITY & FEATURES

KEYBOARD SHORTCUTS

NAVIGATION TIPS

*Keyboard Navigation*

The Keyboard Shortcuts for Panning and Zooming a Diagram may be invoked at any time (while not active within another command) while working in a Visio Diagram. The five Keyboard Shortcuts are:

**Zoom In to a Designated Rectangular Area** [ Ctrl+Shift+Left-Click, Drag & Release ]

Press down and hold the Control and the Shift keys on your keyboard. While these two keys are depressed, Click and Hold Down the Left Mouse Button, and drag out a rectangular or “windowed” area to designate the rectangular area you wish to view. Notice that the Mouse Cursor Icon changes to a small “magnifying glass” icon. When you have selected the appropriate area, release the Left Mouse Button, and then the Control and Shift keys. The resultant view will be as close as possible to the area designated. The reason that it will be “as close as possible” is due to the fact that the view still will conform to the aspect ratio of the window the view resides in. The center of the view will be the center of the rectangle used to create the view.

**Zoom In Incrementally** [ Ctrl+Shift + Left Mouse Click ]

Press down and hold the Control and the Shift keys on your keyboard. Notice that the Mouse Cursor Icon changes to a small “magnifying glass” icon. While these two keys are depressed, Click the Left Mouse Button one or more times. Each time you Click the Left Mouse Button while simultaneously holding down the Control and Shift keys, Visio Will Zoom In centered on the location of your Mouse Cursor.

**Zoom Out Incrementally** [ Ctrl+Shift + Right Mouse Click ]

Press down and hold the Control and the Shift keys on your keyboard. Notice that the Mouse Cursor Icon changes to a small “magnifying glass” icon. While these two keys are depressed, Click the Right Mouse Button one or more times. Each time you Click the Right Mouse Button while simultaneously holding down the Control and Shift keys, Visio Will Zoom Out centered on the location of your Mouse Cursor.

**Zoom Out to the Whole Page** [ Ctrl+Shift+W ]

Press the Control, Shift, and W keys on the keyboard at the same time and release them. Visio will zoom in or out such that the currently active Window is filled with the entire Page view. If the Page is in a Landscape mode, that is, it is wider that it is tall, the view will fill more of the Window than if the Page is in Portrait mode. This is because Visio will read the Height and Width of the Page and use the values to fit the Page within the Window based upon the aspect ratio of the Window.
Pan Around the Diagram at the Current Zoom Level [ Ctrl+Shift+Right-Click, Hold ]
Press down and hold the Control and the Shift keys on your keyboard. While these two keys are depressed, Click and Hold Down the Right Mouse Button. While these are all being pressed and held, move the mouse slightly in any direction. Notice how the Cursor has changes to a small “hand” icon. While all of these are held down and depressed, move the mouse at will and Visio will follow, panning the diagram at the current zoom ratio. Releasing the Control and Shift keys while releasing the Right Mouse Button will stop this action.

Mouse-Based Navigation
The behavior of the IntelliMouse Wheel is based upon a setting in the Visio Tools > Options… Dialog. Selecting Tools > Options… from the Visio Tools Menu displays the Visio Options Dialog. Within the Options Dialog there are six tabs across the upper are of the Dialog. Clicking on the “General” tab displays many different Check Boxes, Radio Buttons, and Scrollable numeric entry Text Boxes. One of these Check Boxes is the “Zoom on roll with IntelliMouse” Check Box. Obviously this has two potential modes; Checked and Un-Checked.

“Zoom on roll with IntelliMouse” Checked
When this Check Box is Checked and the OK Command Button has been Clicked to confirm the choice and closed, scrolling the Mouse Wheel by rolling the Mouse Wheel Zooms the View In and Out centered on the currently located center of the view.

“Zoom on roll with IntelliMouse” Un-Checked
When this Check Box is Un-Checked and the OK Command Button has been Clicked to confirm the choice and closed, scrolling the Mouse Wheel by rolling the Mouse Wheel Pans the Visio Diagram Up and Down in the current Drawing Window. If the user’s mouse has the newer-generation wheel which may be pressed Left or Right, pressing the wheel Left Pans the Diagram Left in the current Drawing Window and pressing the wheel Right Pans the Diagram Right in the current Drawing Window.

When the “Zoom on roll with IntelliMouse” Check Box Check Box is Un-Checked, holding the Control key while rolling the Mouse Wheel causes Visio to Zoom the Diagram View In and Out in the current drawing Window centered on the current center of view.

Pan & Zoom Window
New, beginning with Visio 2003 is the Float-able / Dock-able Pan & Zoom Window. It is accessed from the Visio View Tab by selecting the View Tab > Task Panes (Drop Down) > Pan & Zoom

Float Window – The window may be located anywhere “floating above” the Visio environment by either Clicking and Dragging the title bar of the Window, or by Right-Clicking anywhere within the Window, its Title, or Border and selecting “Float Window” (Accelerator W) from the Window’s context menu.

Dock Window – The Window may be docked anywhere against any side of the drawing window or within the Shapes Pane by simply dragging it into position.

Auto-Hide (Pin) Window – In order to save on “real estate” within the Visio environment, the float-able / dock-able Pan and Zoom window may be “hidden” or minimized when not in use. To accomplish this, simply ensure that the window is docked against the edge of the drawing environment and click on the small “push-pin” icon in the title bar of the window. When the window is active it expands to the user selected size. When inactive, i.e. when the user clicks away from the window, the window collapses to a
minimalist view, showing only its title bar. Moving the mouse cursor over the title bar again, re-activates and expands the window.

**Resize Window** – The window is resizeable by the user at will. To resize the window, simply locate the mouse cursor over an edge or corner of the window (the cursor becomes a double-headed arrow), click and drag the window to its new desired proportions.

On the Right-hand-side of the window a slider with Icons at top and bottom exists. These elements allow you to zoom in and out based on positional values.

**Zoom Out Button** – The magnifying glass icon with the minus (-) sign controls the incremental zooming out in the Pan & Zoom window and hence the actual Drawing Window. Click on the Magnifying Glass with Minus Sign icon to incrementally step out in Zoom magnification.

**Zoom In Button** – The magnifying glass icon with the plus (+) sign controls the incremental zooming in, in the Pan & Zoom window and hence the actual Drawing Window. Click on the Magnifying Glass with Plus Sign icon to incrementally step in, in Zoom magnification.

**Zoom Slider Bar** – The thumb and slider control allows the view to be zoomed in and out by positioning the thumb along the slider.

**Left-Click Drag Out Zoom Box Area Define** – The view area can be defined by Clicking, and dragging out a defining rectangle to specify the zoom area.

**Resize Zoom Box Area** – To resize the zoom rectangle, click and drag a corner or edge of the red zoom rectangle designation box, and release at the desired proportional change in size.

**Reposition Zoom Box Area** – To reposition the zoom rectangle, click and drag anywhere within the red zoom rectangle designation box, and release at the desired new position for the zoom rectangle.

**Window Scroll Bars**

The typical Windows Scroll Bars found in most Windows applications and their standard behavior apply in exactly the same manner within the Visio environment.

**Vertical Scroll Bar**

The Vertical Scroll bar at the Right of the Visio Diagramming Window Pans the Diagram View Up and Down. Click and Drag the Thumb along the slider to adjust the view position up or down.

**Horizontal Scroll Bar**

The Horizontal Scroll bar at the Bottom of the Visio Diagramming Window Pans the Diagram View Right and Left. Click and Drag the Thumb along the slider to adjust the view position right or left.

**Zoom Percentage Drop-Down List**

The Zoom Percentage Listing is found on the View Tab by selecting the View Tab > Zoom (in the Zoom collection area)

400% - Zoom to exactly 400 percent of the printed size of the Diagram
200% - Zoom to exactly 200 percent of the printed size of the Diagram
150% - Zoom to exactly 150 percent of the printed size of the Diagram
100% - Zoom to exactly 100 percent of the printed size of the Diagram
75%- Zoom to exactly 75 percent of the printed size of the Diagram
50%- Zoom to exactly 50 percent of the printed size of the Diagram
Last– Zoom to the last used Zoom Percentage and Position
Width – Zoom such that the Width of the Page fits to the edges of the current Window
Page– Zoom such that the entire Page fits into the current Window
Typed Zoom Percentage Value - Type in a value for the desired Zoom Percentage. This number (entered as an integer with a trailing Percent symbol [ % ] ) indicates the percentage of the printed size that you wish to have the Zoom value recognize. It is also implicitly understood to be based upon the Center of the Page.

**Best Practices**

While there is no singular “best” methodology for navigating around a Visio diagram, learning the keyboard shortcuts or utilizing the Pan & Zoom Window will dramatically decrease the time spent in maneuvering around the diagramming area during Visio editing sessions. In many years of Visio usage, the keyboard shortcuts have, indeed, proved to be the most effective methodology.

**CONNECTING Visio SmartShape Symbols**

**HOW TO CONNECT SmartShape symbols WITH THE NEW 2010 AUTOCONNECT FEATURE**

**Step One:**
Drop the first SmartShape symbol and get it placed at the appropriate location.

**Step Two:**
Float the Mouse cursor over the first SmartShape symbol. Note that four faint blue triangles appear above, below, left, and right, of the first SmartShape symbol’s Bounding Box. Float your cursor over any one of these triangles. Note that the first four Master SmartShape symbol shown on the active Stencil will be displayed at the cursor. Select any one of the desired four SmartShape master symbols and it will be automatically added, connected to the first SmartShape symbol, and properly spaced on the drawing page.

If, for any reason you do not see the blue triangles while hovering over a SmartShape symbol, go to the View Tab and ensure that the AutoConnect check-box is checked in the Visual Aids group.

The methodology for this glue utilizes a type of glue called “Dynamic” or “Shape-to-Shape” glue.

**HOW TO CONNECT SmartShape symbols WITH THE 2007 AUTOCONNECT FEATURE**

**Step One:**
Drop the first SmartShape symbol and get it placed at the appropriate location.

**Step Two:**
Left-Click to select the desired second SmartShape Master on the Stencil.
**Step Three:**
Float the Mouse cursor over the first SmartShape symbol. Note that four faint blue triangles appear above, below, left, and right, of the first SmartShape symbol’s Bounding Box. Click on any one of these triangles. The Master SmartShape symbol that was selected on the Stencil will be automatically added, connected to the first SmartShape symbol, and properly spaced on the drawing page.

If, for any reason you do not see the blue triangles while hovering over a SmartShape symbol, move the mouse cursor up to the Standard Toolbar and Locate the AutoConnect Toolbar item (located immediately to the left of the drop-down zoom listing), and ensure that the AutoConnect tool is selected. This tool should, by default, be already selected.

The methodology for this glue utilizes a type of glue called “Dynamic” or “Shape-to-Shape” glue.

**HOW TO CONNECT SmartShape symbols with POINT-TO-POINT GLUE AND DYNAMIC GLUE**

In the Visio environment there are specifically two types or modes of Glue: (1) Point-to-Point, and (2) Shape-to-Shape, or Dynamic, Glue. The methodologies of establishing either of these types of glue differ, as does the behavior of the Dynamic Connector after the Glue is established.

**Point-to-Point Glue**
Point-to-Point Glue is established by dragging the Begin or End **Point** of the Dynamic Connector directly over the Connection **Point** of the target SmartShape symbol. The Visio 2010 before, and after, visual indicators of this Glue type are illustrated below.

![Diagram 1](image1)

Notice that when Point-to-Point Glue is established, the Beginning, and Ending indicators on the Dynamic Connectors change from a White Box with Blue Line at the Begin Point of the Connector and a Blue Box with Blue Line at the End Point of the Connector to a White Box with a Red Line at the Begin Point of the Connector and a Red Box with a Red Line at the End Point of the Connector.

Point-to-Point Glue is, exactly that: the Begin or End Point of the Dynamic Connector is Glued to the specific Connection Point on the target SmartShape symbol. When the target SmartShape symbol is relocated, the Glue remains intact. If the Begin or End Point of the Dynamic Connector is relocated, the Glue is broken. Keep in mind that the glue is point-to-point and because Dynamic connectors always attempt to route AROUND SmartShape symbols, the visual routing of the Dynamic Connector may not be as expected. However, the Dynamic Connector is doing **EXACTLY** what was asked of it. It is going directly **FROM** the SPECIFIC Connection Point on the First SmartShape, **DIRECTLY** TO the SPECIFIC Connection Point on the Second SmartShape symbol and routing around the two target SmartShape Symbols. This is why the resultant routing looks something like the illustration below.
Dynamic (or Shape-to-Shape) Glue

Shape-to-Shape, or Dynamic Glue is established by dragging the Begin or End Point of a Dynamic Connector over the INTERIOR of the Target SmartShape Symbol until the Target SmartShape symbol’s Bounding Box turns Red, then releasing.

The resultant Dynamic Glue is indicated by much larger Red Glue Indicators on the Dynamic Connector as illustrated below.

Notice that when Dynamic Glue is established, the Beginning, and Ending indicators on the Dynamic Connectors change similar to Point-to-Point Glue, however they display an additional Box around the Begin and End Points to indicate Dynamic, or Shape-to-Shape Glue.

Dynamic, or Shape-to-Shape Glue is, exactly that: the Begin or End Point of the Dynamic Connector is Glued to the target SmartShape symbol as a whole. When the target SmartShape symbol is relocated, the Glue remains intact. If the Begin or End Point of the Dynamic Connector is relocated, the Glue is broken. Keep in mind that the glue is shape-to-shape. This changes the behavior of the Dynamic connector. The Dynamic Connector looks for the MOST DIRECT routing between the SmartShape symbols. The Dynamic Connector is doing EXACTLY what was asked of it. It is going directly FROM the Pin Point on the First SmartShape, directly TO the Pin Point on the Second SmartShape symbol and finding the MOST DIRECT ROUTING between the two target SmartShape Symbols. This is why the resultant routing looks something like the illustration below.

If two SmartShape symbols, connected by a Dynamic Connector SmartShape symbol are located on the Diagram Page and another SmartShape symbol is desired between the two SmartShape symbols, there is no need to delete the Dynamic Connector SmartShape symbol, add the new SmartShape symbol and re-connect with two additional Dynamic Connector SmartShape symbols. Since the introduction of Visio 2003, a new feature called the “Connector Splitter” feature is available to flow diagrams.

To add a new SmartShape symbol between two existing SmartShape symbols (connected by a Dynamic Connector SmartShape symbol), with Visio 2003, and Visio 2007 simply ensure that there is enough room to fit the new SmartShape symbol between the existing two. With Visio 2010 there is no need to reposition SmartShape symbols to make room, Visio 2010 will automatically adjust the spacing for you. Next Left-Click, Drag, and hover the new SmartShape symbol over the Dynamic Connector SmartShape symbol. Notice with Visio 2003 and Visio 2007 that the cursor becomes a pair of scissors mouse cursor icon. Utilizing Visio 2010, the endpoints of the Connector will become very large Red Boxes with no lines around them. While the scissors icon is showing (Visio 2003 and Visio 2007), release the Left Mouse Button, or with Visio 2010, when the Connector Endpoints are large red boxes, release the Left Mouse Button. Notice that the Dynamic Connector SmartShape symbol has been “split”, the new SmartShape symbol is in place with a new Dynamic Connector SmartShape symbol connecting the new SmartShape symbol at opposite ends already properly glued with Dynamic Glue.

Any text on the pre-existing Dynamic Connector SmartShape symbol has been added to both new Dynamic Connector SmartShape symbols.

DYNAMIC CONNECTOR BEHAVIORS AND MANIPULATION

Adding and “bending” Leg Segments

Any time a Dynamic Connector SmartShape symbol is placed on the Visio Diagram Page, and the Dynamic Connector SmartShape symbol is selected (presuming that the Dynamic Connector SmartShape symbol is currently in Right-Angle mode), small green (Visio 2007 and prior) or blue (Visio 2010) handles are visible at the mid-point of each leg segment of the Dynamic Connector SmartShape symbol.

Left-Clicking, and Dragging any of these green (Visio 2003 or 2007) or blue (Visio 2010) handles relocates the position of that particular leg segment.

If you hold down the “Ctrl” key while Left-Clicking and Dragging any of these green handles, the leg segment will “bend” at an angle forming two leg segments “bent” at the desired angle at the point of release.
If you hold down the “Shift” key while Left-Clicking and Dragging any of these green (Visio 2003 or 2007) or blue (Visio 2010) handles, three new leg segments will appear and be added to the Dynamic Connector SmartShape symbol.

*Changing Dynamic Connectors between Right-Angle, Straight, and Curved mode*

All three modes for Dynamic Connectors are configurable by simply Right-Clicking on the Dynamic Connector SmartShape symbol and selecting either (a) Right-Angle Connector, (b) Straight Connector, or (c) Curved Connector from the Dynamic Connector SmartShape symbol’s context menu.

While the Dynamic Connector SmartShape symbol is in Straight Connector mode, the begin, and end-points of the Dynamic Connector SmartShape symbol will react in the following manner:

Glued with Point-to-Point glue, the begin and end points will be specifically glued to the desired connection points and the line on the Dynamic Connector SmartShape symbol will be in a straight line between these two connection points.

Glued with Dynamic, or Shape-to-Shape glue, the begin and end points will be specifically glued to the center of each of the 2-D SmartShape symbols and the line on the Dynamic Connector SmartShape symbol will be in a straight line between these two SmartShape symbols, stopping at the closest edge of each of the 2-D symbols.

While the Dynamic Connector SmartShape symbol is in Curved Connector mode, several green (Visio 2003 or 2007) or blue (Visio 2010) handles will be displayed allowing you to bend the curvature of the Dynamic Connector SmartShape symbol’s line to the form that best suits your needs. Also while the Dynamic Connector SmartShape symbol is in Curved Connector mode, the begin, and end-points of the Dynamic Connector SmartShape symbol will react in the same manner as the Straight Connector with regard to the endpoints of the Dynamic Connector SmartShape symbol’s connectivity.

**NOTE:** Utilizing Visio 2010, by selecting the Design Tab, looking to the far right side of the Ribbon, you will see a Connectors item on the Layout Area of the Design Tab. Modifying the selection to either Right Angle, Straight Lines, or Curved Lines will update ALL connectors in the diagram, rather than just the selected connector. Additionally there is an option to show or hide line jumps on a diagram-wide basis.

*Adding, Relocating, Deleting and Changing the Behaviour of Connection Points on SmartShape Symbols*

Every SmartShape symbol can have as many Connection Points associated with them as you desire. By default many SmartShape symbols have four Connection Points associated with them. These Connection Points tend to be located at the Top-Center, Bottom-Center, Left-Middle, and Right, Middle of the edges of these SmartShapes’ Bounding Box.

These Connection Points are shown on the SmartShape symbols by default as blue “X” indicators (Under Visio 2010, these connection points are only visible as you drag a connector near the SmartShape symbol. They are still available and active, simply not visible unless they are needed). This type of Connection Point is called an “inward facing” Connection Point. 1-D SmartShape symbols’ Begin Points, End Points, or Control Handles glue TO these Inward Facing Connection Points.

*Adding Connection Points.*

Connection Points can be added to any SmartShape symbol at any time by utilizing the Connection Point Tool on the Standard Visio Toolbar (Under Visio 2010 this is found on the Ribbon, on the Home Tab, in the Tools area). The Connection Point Tool is selected by finding the Dynamic Connector Tool on the Standard Toolbar.
The Connector Tool looks like a small Dynamic Connector. Notice that immediately to the Right of the Dynamic Connector Tool there is a small black down-pointing triangle. Clicking on this down-pointing triangle reveals a swapping menu where you can select the Connection Point Tool (Note that with Visio 2010, there is no need to swap between the Connector Tool and the Connection Point Tool. Both are available for selection at any time).

Clicking on the Menu item listed as “Connection Point Tool” under Visio 2003 and 21007 sets the tool selection to the Connection Point Tool.

When this Connection Point Tool is selected, your cursor will look like a standard white arrow cursor, however it will have a small blue “X” at its tip.

With the Connection Point Tool selected, Left-Click on the SmartShape symbol which will need the additional Connection Point. The SmartShape symbol will display its Bounding Box without any sizing handles.

Locate the Mouse Cursor directly over the place where the Connection Point is to be added.

With the Connection Point Tool selected, hold down the Control Key on the keyboard and Click the exact location where the Connection Point is to be added. Visio will add a new Connection Point at this location (even if a Connection Point already exists at this location). The new Connection Point will be selected and shown in Magenta color.

Note that Connection Points DO NOT need to be located only at the edge of a given SmartShape symbol. Connection points can be located at ANY point inside, on the edge of, or outside of a selected SmartShape symbol. Ensure that the SmartShape symbol is selected, ensure that the Connection Point Tool is selected, hold the Control Key down, and Click where the new Connection Point is desired.

Relocating Connection Points

Often a given SmartShape symbol will have Connection Points in locations that are less than desirable. There is no reason to tolerate having a Connection Point being located in a location that is less than optimally useful. To relocate a Connection Point, Select the Connection Point Tool as detailed above, Select the subject SmartShape symbol, Click on the Connection Point that needs to be relocated. It will highlight in Magenta to indicate that it is selected. Next, Click and hold, and drag the Connection Point to its desired new location.

Deleting Connection Points

There may be times when a Connection Point is simply not necessary on a given SmartShape symbol. Rather than let this irritation remain it is a very simple matter to eliminate the Connection Point all together. To delete a Connection Point, Select the Connection Point Tool as detailed above, Select the subject SmartShape symbol, Click on the Connection Point that needs to be deleted. It will highlight in Magenta to indicate that it is selected. While the Connection Point is highlighted, simply press the Delete key on the keyboard. The Connection Point is now eliminated.

2D TO 2D GLUE

Every Connection Point on a Visio SmartShape symbol actually has three modes of behavior. By default a Connection Point is defined as being an “Inward” facing Connection Point. It is visually indicated by a Blue “X” when the SmartShape symbol is selected.

This mode allows any valid part of a 1-D SmartShape symbol, such as a Begin Point, an End Point, or a Control Handle to Glue to the Connection Point.
By selecting the 2-D Process SmartShape symbol and then selecting the Connection Point Tool (as described above) it is possible to Click and select an individual Connection Point on a SmartShape. To change the Connection Point style from the default “Inward” facing to an “Outward” facing style, Right-Click on the selected Connection Point to display its context menu and select Outward from the context menu.

Clicking on the “Outward” option changes the Connection Point from a default “Inward” facing connection to an “Outward” facing connection. The graphical representation of the Connection Point changes from a small blue “X” to a small blue “box”.

Why would one care about changing a Connection Point from an Inward to an Outward facing Connection? Because Outward Facing Connection Points can Glue directly to Inward Facing Connection Points. This allows a 2-D SmartShape to be Glued directly to another 2-D SmartShape symbol. Keep in mind that the same basic rules of gluing still apply. Just as a 1-D SmartShape symbol glues TO a 2-D SmartShape symbol, and not the other way around, an Outward facing Connection Point glues TO an Inward facing Connection Point and not the other way around.

The third option for Connection Point behavior as shown on the context menu above is “Inward & Outward”. This, obviously, means that the Connection Point can serve as either an Inward or an Outward facing Connection Point. Its graphical representation is as a combination of the blue “X” for Inward and the blue “box” for Outward.

Think of these Outward to Inward Connection Point glue behaviors as the snap together blocks that wee toddlers play with. These particular glue behavior chains can be linked together to form linked series of 2-D SmartShape symbols. This brings about numerous possibilities for associated symbology behaviors. Please do note, however, that currently under Visio 2007, the limitation for maintaining the glue in these instances are a maximum of ten (10) linked glue connections. After 10 connections, Visio currently refuses to recognize any further glue connections in that particular chain.

**Themes**

By default, as Visio creates the Organization Chart Diagram, whether manually or via the Organization Chart Wizard, Visio creates white boxes on a white background. Certainly, as was discussed earlier, Background pages can be added to the diagram. Regardless of Background or not, the user is still confronted with white boxes. This is certainly less than desirable.

Visio provides a new technology to update an entire diagram with a selected palette of colors and formatting options designed to make the Organizational Diagram far more attractive to the viewer of the Organization Chart Diagram. The color and formatting options are part of a new technology called “Themes”. Themes encompass colors and formatting for each element in a Visio diagram. They are consistent across all Visio diagram types. They are also the same themes that can be found in every Microsoft Office 2007, and 2010 application. This ensures a consistent “look and feel” across every document and diagram produced by any group within the organization.

In Visio 2007, there are two elements to Themes: Theme Colors, and Theme Effects. In Visio 2010, there are combined Theme Colors and Effects, just Theme Colors, and just Theme Effects.

To access Themes in Visio 2007, choose Format   Theme... from the Visio Format menu.

This action displays the Theme Task Pane, by default, sized and docked to the Right side of the Visio Environment.

To access Themes in Visio 2010, go to the Design Tab on the Ribbon, and find the Themes Area.
THEME COLORS
In Visio 2007, Theme Colors will be displayed by default (In Visio 2010 Combined Theme Colors and Effects take up the majority of the Themes area, Theme Colors and Theme Effects are drop-downs at the right of the Theme Area of the Design Tab). Near the top of the Theme Task Pane (Visio 2007), there are two entries, Theme Colors and Theme Effects. Left-Clicking on either of these two entries will display that particular Theme Task.

Theme colors are a pre-defined palette of color sets. To apply any Theme Color, Select one or more SmartShape symbols and then Left-Click on any desired Theme Color. The Theme Color will be applied.

If, for any reason, a mistake has been made or it has been determined that none of the Themes provided are acceptable, Left-Clicking on the None Theme will clear any applied Theme. Additionally at the very bottom of the Theme Pane (Visio 2007) or at the bottom of the Theme Color drop-down list (Visio 2010), there is a New Theme Color... item which may be Left-Clicked and then a new palette of colors saved under a new Theme name.

THEME EFFECTS
Theme Effects, like Theme Colors, are a palette of formatting options including things like line style and weight, fill patterns, and corner rounding.

If, for any reason, a mistake has been made or it has been determined that none of the Themes provided are acceptable, Left-Clicking on the None Theme will clear any applied Theme. Additionally at the very bottom of the Theme Pane (Visio 2007) or at the bottom of the Theme Effects drop-down list (Visio 2010), there is a New Theme Effects... item which may be Left-Clicked and then a new palette of formatting options saved under a new Theme name.

ADDITION, MODIFYING, AND DELETING SHAPE DATA (CUSTOM PROPERTY) FIELDS
As you have seen, Visio is, at its core, a brilliant graphics engine for visualizing data and processes. Part of the reason for this, is the ability for any SmartShape symbol, and even the Page itself, to store, and retrieve data. Under Visio 2007 and Visio 2010 this stored data is called Shape Data. Prior to Visio 2007 this stored data was called Custom Properties. There is absolutely no difference between Shape Data and Custom Properties, it is singularly the name by which they are referred to which has been changed with the latest release.

Many Master SmartShape symbols already have Shape Data defined and associated with them. A classic example of this are most of the Basic Flowchart SmartShape symbols. These SmartShape symbols all have three Shape Data fields: Cost (a Currency field), Duration (a Duration Field), and Resources (a String Field to hold either a number or a text string) under Visio 2007 and prior. Under Visio 2010, the Basic Flowchart SmartShape symbols now have the following Shape Data Fields: Cost (a Currency field), Process Number (a Numeric field), Owner (a String field), Function (a String field), Start Date (a Date/Time field), End Date (a Date/Time field), and Status (a Variable List field [similar to a Combo-box]).

By having the user enter values into these fields Visio can then generate reports, utilize the new Visio 2007 and 2010 Data Graphics to display Key Performance Indicators, and create many other powerful visual status reports for Flow diagrams. These diagrams then can convey much more that simple boxes with text typed into them.

In many instances the Shape Data that is already pre-defined with the SmartShape symbol will be sufficient. However there will be occasions where the user will want to store much more data than has
already been defined with the SmartShape symbol. Visio has made it very easy to create new Shape Data fields, Edit existing Shape Data fields, and remove un-needed Shape Data fields.

Creating Shape Data

To create (or edit the definition of) Shape Data fields, Right-Click on any SmartShape symbol (or, again, even the page itself) and choose Data ➤ Shape Data… from the Context menu. Alternatively, under Visio 2003 or 2007, choose Data ➤ Shape Data… from the Visio Data Menu. Under Visio 2010, go to the Data Tab of the Ribbon, and ensure that the Check Box for Shape Data Window is selected. Then, under Visio 2010, Right-Click on the Shape Data Window and select Define Shape Data, from the Context Menu.

Either of these techniques will display the Shape Data dialog, or if no Shape Data is already defined and associated with the SmartShape, will display the Message Box letting you know that “No shape data exists” and will ask you, “Do you want to define shape data now?”

Click the Yes Command Button to close the message box and display the Define Shape Data dialog.

Note: ensure PRIOR to defining Shape Data that under Visio 2003 and 2007, on the Advanced Tab in the Tools ➤ Options dialog the Check Box for “Run in Developer Mode” is checked. This will ensure that every available option in the Define Shape Data dialog will be displayed. Under Visio 2010 this same option will be found by selecting the File Tab on the Ribbon, going to the Backstage area, and Left-clicking on the Options item at the Left. In the Options Dialog, Left-click on the Advanced item at the left, scroll down to the bottom of the Advanced area and ensure that the Check Box for “Run in Developer Mode” is checked in the General area. Confirm by selecting the OK Command Button and return to the drawing environment by Left-clicking on the File Tab on the Ribbon again.

The first available field in the Define Shape Data dialog is the Label: field. This field holds a String. It can contain any form of text including spaces. This is the label which is visible in either the Shape Data dialog or the Scrollable / Dockable Shape Data Window.

The second available field in the Define Shape Data dialog is the Name: field. This field defines the actual name of the Shape Data field defined and associated with the SmartShape symbol or page. This field is used internally by the ShapeSheet of the SmartShape symbol (or the page). The rule for the naming of the field is similar to most programming schemas in that this field can contain no spaces. For visual clarification this field CAN use the underscore character. As an example, if a field designated to hold User Name information, the Name field could be “UserName” or “User_Name”, but could NOT be “User Name”.

The third available field in the Define Shape Data dialog is the Type: field. This field defines the Data Type of the Shape Data field defined and associated with the SmartShape symbol or page. The available Data Types are : String (Text), Number (integers or Doubles), Fixed List (akin to Drop-Down List), Variable List (akin to Combo Box), Boolean (True or False), Currency, Date, and Duration.

The fourth available field in the Define Shape Data dialog is the Format: field.

If the Data Type defined above is Text, this will be: All Upper Case, All Lower Case, or Normal (Mixed Case).

If the Data Type is Number, this will be: General Number, General Number with Units, Whole Number (integer), Whole Number with Units (integer with units), Floating Point (double), Floating Point with Units (double with units), Fraction (numerator as an integer divided by denominator as an integer), Fraction with Units (numerator as an integer divided by denominator as an integer with units).

If the Data Type is a Fixed List or a Variable List this will be a semi-colon delimited list as in “A;B;C;D”.
If the Data Type is a Boolean this will be unavailable since the possible values will exclusively TRUE (non-zero) or FALSE (zero).

If the Data Type is Currency this will be (in the US): the System Setting, $Integer, $Double (2 decimal places of precision), Double (2 decimal places of precision with the string “United States Dollar”), or Double (2 decimal places of precision with the string “USD”).

If the Data Type is Date this will be in the form of: Short Date 4-digit year (10/3/1993), Verbose Date (Sunday, October 3, 1993), Full Date (October 3, 1993), Short Date 2-digit year (10/3/93), Numeric Year-Month Day (1993-10-03), 3-Oct-93, 10.3.1993, Oct. 3, 93, 3 October 1993, October 93, Oct-93, 10/3/1993 5:00 PM, 10/3/1993 5:00:00 PM, 5:00 PM, 5:00:00 PM, 17:00, or 17:00:00.

If the Data Type is Duration this will be in the form of: Weeks, Days, Hours, Minutes, Seconds, Hours and minutes (1:23), or Minutes and seconds (0:12).

The fifth available field in the Define Shape Data dialog is the Value: field. If a default value is desired, it can be primed in this field. This field may also be left blank.

The sixth available field in the Define Shape Data dialog is the Prompt: field. This field is a Text String field which displays at the lower area of the Shape Data dialog when a given field has the focus, or displays as a tool tip in the Shape Data Window when the Mouse Cursor is hovered over the Label field for any Shape Data item. This field is constructed to provide input and feedback to the user while they are entering data into the Shape Data fields. It acts as a “mini-help” to guide the user in properly entering the requested data.

The seventh available field in the Define Shape Data dialog is the Sort key: field. This field is an ASCII Character Code-based field to establish the order that the individual Shape Data fields will be displayed in either the Shape Data dialog or the Shape Data Window. To clarify, this field is NOT numeric in sequence, nor is it Alphabetical in sequence. It is in ASCII Character Code sequence. For example, if the user had defined 12 Shape Data fields and the user had entered the numbers 1 through 12 in the Sort key fields, the order would end up as 1, 10, 11, 12, 2, 3, 4, 5, 6, 7, 8, and 9. If the user actually wanted them to be numerically sequenced they should be entered as 01, 02, 03, 04, 05, 06, 07, 08, 09, 10, 11, and 12.

The eighth available field in the Define Shape Data dialog is the “Ask on drop” Check Box. If this box is checked then when the SmartShape symbol that has that particular field, or those particular fields, flagged as “ask on drop” is either dropped from a Stencil or copied by any means, those particular fields will be displayed in an abbreviated Shape Data dialog. At any later time, the user will still have access to the all of the Shape Data fields with any subsequent call to the Shape Data dialog or via the Shape Data Window. This flag simply prompts the user to provide data to these flagged fields immediately on the instancing of the SmartShape symbol.

The ninth available field in the Define Shape Data dialog is the “Hidden” Check Box. If this box is checked the Shape Data field will still be created and associated with the particular SmartShape symbol or the Page, however the particular field with this flag will NOT be displayed in either the Shape Data dialog or in the Shape Data Window.

Upon completion of each of the fields in the Define Shape Data dialog for that particular Shape Data item you can either elect to Left-Click on the OK Command button to accept the definition and close the dialog and display the Shape Data dialog, or Left-Click on the New Command Button to begin defining another Shape Data item.
Any SmartShape symbol or the Page can have as many Shape Data items associated with the SmartShape symbol or the Page. There is, however a limitation in the Shape Data dialog which is Screen Resolution-based. When the Shape Data dialog is displayed, depending upon the screen resolution of the viewer’s PC the dialog is capable of only displaying between 19 and 24 Shape Data items. If more than this amount of items are defined, a message will be displayed at the bottom of the dialog that additional Shape Data items are not being displayed. These limitations DO NOT exist in the Shape Data Window. The Shape Data Window is a scrollable window and as such can display as many Shape Data items as are defined with the SmartShape symbol or the Page.

**Editing Shape Data**

When a SmartShape symbol containing Shape Data is selected, you can either choose Data ➤ Shape Data... from the Context menu or, alternatively choose Data ➤ Shape Data... from the Visio Data Menu. This will cause the Shape Data dialog to display and be populated with the defined Shape Data items.

When no SmartShape symbol is selected, you can still either choose Data ➤ Shape Data... from the Page’s Context menu, or alternatively choose Data ➤ Shape Data... from the Visio Data Menu (Visio 2003 and 2007). This will cause the Shape Data dialog to display and be populated with the defined Shape Data items for the Page. Under Visio 2010, go to the Data Tab of the Ribbon, and ensure that the Check Box for Shape Data Window is selected.

When the Shape Data dialog is active, the user simply Left-Clicks into the desired Shape Data field, reads the prompt and fills in the requested information or selects from the available list of choices in the list. When the editing is complete, the user then Left-Clicks the OK Command Button to confirm the changes and close the dialog.

By choosing View ➤ Shape Data Window from the Visio View Menu, the Shape Data Window is displayed. While this window is displayed, simply Left-Clicking on any SmartShape symbol will fill the contents of the window with that particular SmartShape symbol’s Shape Data. If no SmartShape symbol is selected then the window will fill with the Shape Data for the Page, if any Shape Data has been defined for the Page. While the Shape Data window is filled with active contents, you simply Left-Click into the desired Shape Data field, float the Mouse Cursor over the Label for that item, read the prompt and fill in the requested information or select from the available list of choices in the list. When the editing is complete, you then simply Left-Click off the selected SmartShape symbol to deselect the SmartShape symbol and empty the Shape Data Window of its contents.

Utilizing the Shape Data Window, multiple SmartShape symbols can be selected and their mutually common contents can be edited simultaneously.

**PAGES AND BACKGROUND PAGES**

**DYNAMIC PAGE RESIZING**

When new diagrams are begun, based on specific Templates in Visio, page size and orientation is preset by the Template definition. If a new diagram is begun based on no template, in the United States, the pre-defined page size and orientation is defined as Portrait / 8.5 in wide X 11 in tall, a default letter sheet in portrait mode. At any time you may change the Page size by selecting File ➤ Page ➤ Setup... , then selecting the orientation and size from the Printer Paper area of the Print Setup Tab. This functionality allows a selection of standard sheet, and therefore Page, sizes from the available lists.

It is also possible to change the Page Size at absolutely any time from the page itself.

To dynamically resize a Visio Page perform the following:
Begin a new Visio Diagram based on the Basic Flowchart Template

- Launch Visio
- Select File ▸ New Flowchart ▸ Basic Flowchart (US Units) (Visio 2003 and 2007)
- (Visio 2010) Left-click the File Tab, Choose the Flowchart Template Category, and select the Basic Flowchart item. Left-click on the desired Units Radio Button at the right, and Left-click the Create item.

This will create a new Visio Diagram based on the Basic Flowchart Template

- Locate the Mouse Cursor at EXACTLY the Right Edge of the Page.
- Hold down the Ctrl Key on the Keyboard

Note that the Mouse Cursor Arrow has changed and become a Double-Headed arrow

- While holding down the Ctrl key on the keyboard, Left-Click, Hold Down and Drag the mouse Cursor to the Right a desired distance, then release the Left Mouse Button

Notice that the Page has now been altered in Width to be the width defined by the amount of the movement of the Mouse Cursor to the Right.

This action can be utilized at any one of the four edges of the page: Left, Top, Right, and Bottom.

This technique of Ctrl+Dragging the page edge to resize can be applied to any page at any time. Note, however, it ONLY affects the drawing page, and not the printer page size.

**BACKGROUND PAGES**

**CREATING A BACKGROUND PAGE**

Creating a Background Page is essentially the same as creating a standard Foreground Page. Creating any page is accomplished under Visio 2003 and 2007 via the Page Setup dialog. It is simply the entry point to the dialog that is different. To tell Visio that a new Page is desired, select Insert ▸ New Page... from the Visio Insert Menu. Under Visio 2010, go to the Insert Tab of the Ribbon, Use the Drop-down under Blank Page in the Pages area, and select “Background Page”. The Page Setup dialog will display.

When displayed, the Page Setup dialog will be active on the Page Properties Tab. In the Type: area, there are two Radio Buttons: Foreground and Background. Select the Background Radio Button. In the Name: area change the name from “Background-(index number i.e. Background-1) to any desired name as required, or leave as is. Click the OK Command Button. The Page Setup dialog will close and the new Background Page will be added to the Pages collection and shown on the series of Page Tabs.

Note that when the Page Setup dialog closes under Visio 2003 and 2007, the newly created Background Page will be the Current Page with the Page focus. Under Visio 2010, the current page will still remain active.

**ASSIGNING A BACKGROUND PAGE TO A FOREGROUND PAGE**

At this point in time the newly created Background Page will not yet be associated with any Foreground Page. To provide any Foreground Page with an associated Background Page, click on the desired Foreground Page Tab to set it as current and with Focus, under Visio 2003 and 2007, select File ▸ Page Setup... from the Visio File Menu. The Page Setup Dialog will be displayed. The Print Setup Tab will be the active Tab in the dialog. Click on the Page Properties Tab to activate it. Under Visio 2010 go to the
Design Tab of the Ribbon, in the very lower-right-hand-corner of the Page Setup area, Left-click on the “Down-Right” pointing corner of the Page Setup Area (or press the Shift+F5 keystroke combination).

Note that the Name field shows the name of the current page. In the Background Drop-Down Listing, select the name of the Background Page that is requested to be assigned to the Foreground Page (in this case Background-1) and Click the OK Command Button to confirm the request. Page-1 (a Foreground Page) now has an assigned Background Page (Background-1).

Think of the Page-1 Page as being essentially a clear sheet of plastic. The user can “see through” Page-1 to its Background Page, BackgroundPage-2, such that anything on the Background Page will be visible on Page-1.

**UTILIZING FIXED ITEMS ON BACKGROUND PAGES [GRAPHICS, TITLE BLOCKS, BORDERS]**

By creating a Background Page and assigning it to an associated Foreground Page you pre-define a Background Page not only for this particular Foreground Page, but additionally, by default, for any additional new Foreground page that you will create. In other words, once the desired Background Page is assigned to Page-1, then each time you add a new Foreground Page (Page-2, Page-3, Page-4, etc.) upon entering the Page Setup Dialog, the Background Drop-Down list will already be pre-primed with the name of the Background Page associated with Page-1. At any time this association may be changed, however it is a very nice time-saving methodology when creating new Foreground Pages.

Another advantage of assigning the same Background Page to many Foreground Pages is that the information (SmartShape symbols, etc.) on the Background Page is added to the Visio diagram only once, and all of the Foreground Pages that need to display this same information can “see” that information without it having to be repetitively added. This results in a great conservation of Visio file size. Remember that image files (.JPG, .GIF, .BMP), unlike standard SmartShape symbols, when instanced multiple times, **DO NOT** become instances of a Master SmartShape symbol. They are unique instances, and as such, consume greater and greater file size with each instance. Therefore adding that fabulous Corporate Logo only once on a Background Page and letting every Foreground Page “see” that logo keeps the Visio Diagram file size much, much smaller than adding the logo in multiple times.

**LAYERS**

**CREATING LAYERS**

The Layer Properties dialog is accessed under Visio 2003 and Visio 2007 by selecting View > Layer Properties... from Visio’s View Menu (Alt+V, L), or, if the Layers Tool bar is being displayed, by selecting the Layer Properties Tool on the Layer Toolbar. Under Visio 2010 go to the Home Tab, and using the drop-down on the Layers item of the Editing area, select Layer Properties...

It is important to remember that Layers are Properties of the Page in Visio. When Layers are added, their definitions are maintained within the ShapeSheet of the Page itself.

To add a new Layer to the collection of Layers for a given Page in a Visio Diagram, open the Layer Properties Dialog and click on the New... Command Button. A New Layer sub-dialog will be displayed. The Text Box in the New Layer sub-dialog allows the name of the New Layer to be entered. When the name has been entered, click the OK Check Box to confirm the entry. The new layer will be added to the list of layers associated with that page.
**LAYER PROPERTIES**

. The main pane within the Layer Properties has a series of rows, one for each layer, and each row has a series of columns that contain Check Boxes which can alter the behavior of that particular aspect of the layer. The discussions below detail the functionality of each of these columns and Check Boxes.

**Name**
The Name Column displays the assigned name of that particular layer.

**#**
The Pound Sign (or Hash Sign) column displays the current number of SmartShape symbols assigned to that layer.

**Visible**
The Visible column contains a Check Box which controls the Visibility of that layer. If checked, any SmartShapes assigned to that layer are visible. If unchecked, any SmartShapes assigned to that layer are invisible.

**Print**
The Visible column contains a Check Box which controls the Print-ability of that layer. If checked, any SmartShapes assigned to that layer will print. If unchecked, any SmartShapes assigned to that layer are will not print.

**Active**
The Active column contains a Check Box which controls the layer assignment of any new SmartShape symbols added to the page that do not already have a layer assignment. For example, presume that Layer is created called Decision. If the Decision Layer’s Active Property is checked and a SmartShape symbol with no previous layer assignment is dropped onto the page, it will automatically be assigned the Decision layer. If the Active Check Box is unchecked, no additional layer assignment will take place.

**Lock**
The Lock column contains a Check Box which controls the accessibility of SmartShape symbols assigned to that layer. If the Check Box is checked, any SmartShape symbol assigned to that layer will be visible (based on its Visible Property setting) however it may not be selected, nor can it be manipulated in any manner. If the Check Box is unchecked, the SmartShape symbols on that layer will be fully selectable and accessible (pending other individual settings).

**Snap**
The Snap column contains a Check Box which controls whether any SmartShape symbol can Snap to a SmartShape symbol assigned to that named Layer. If the Check Box is checked any SmartShape can Snap to SmartShape symbols assigned to that layer. If the Check Box is unchecked any SmartShape cannot Snap to SmartShape symbols assigned to that layer.

**Glue**
The Glue column contains a Check Box which controls whether any SmartShape symbol can Glue to a SmartShape symbol assigned to that named Layer. If the Check Box is checked any SmartShape can Glue
to SmartShape symbols assigned to that layer. If the Check Box is unchecked any SmartShape cannot
Glue to SmartShape symbols assigned to that layer.

**Color**

The Glue column contains a Check Box which controls the Color assignment for all SmartShapes assigned
to that Layer. The Color is assigned by selecting the color from the Layer Color Drop-Down List Box.

**NOTE!** Assigning a Color to a Layer changes the LINE COLOR for the SmartShape symbols on that Layer
to the selected color. Under Visio 2003 and Visio 2007 it does NOT change the fill color for the
SmartShape symbols assigned to that layer, rather the fill color changes from its pre-assigned individual
color to White (01). Under Visio 2010, the Pattern Color as well as the Line Color change. For example, if
a Process SmartShape symbol on the Flowchart Layer had been modified to have a fill color of blue and a
line color of green and then the Color Property of the Flowchart is set to Red, the SmartShape symbol’s
Fill would become White (under 2010 with a pattern color of Red) and its Line Color would become Red.
If the Color Property Check Box were then unchecked, the Fill color would revert to blue and the line
color would revert to green again.

**ASSIGNING SmartShape symbols TO LAYERS**

Above, it was documented that Layer assignments are properties of the Page. Assigning a Layer or
Layers to a SmartShape symbol such that the particular SmartShape symbol has that layer association or
association of layers is accomplished via the Layer dialog (note that this is NOT the Layer Properties
dialog). The Layer Dialog, under Visio 2003 and 2007, is accessed by either Right-Clicking on a
SmartShape symbol and selecting Format > Layer... from the SmartShape symbol’s context menu (Alt+O,
R) or by selecting the SmartShape symbol and choosing Format > Layer (Alt+O, R) from the Visio Format
Menu. Completion of either action displays the Layer Dialog. Under Visio 2010 go to the Home Tab, and
using the drop-down on the Layers item of the Editing area, select Assign To Layer...

To assign a SmartShape symbol to a Layer or any number of Layers, simply Check the Layer or Layers
that are desired in the dialog. Clicking the OK Command button completes the layer assignment.

**GUIDES**

An elegant, though often neither discovered, nor understood, feature in Visio is the Guides feature.
Guides are specialized SmartShape symbols that act as alignment tools. SmartShape symbols can be
 glued to Guides and the Guides serve as alignment tools as well as ease of mass-movement tools for all
SmartShape symbols glued to the guides.

A point to remember is that Guides NEVER PRINT! (Well.. that’s not exactly true... If you are publishing
the Visio diagram to a PDF file format utilizing the PDF Plug-In provided by Microsoft as part of Microsoft
Office 2007, the Guides will show in the PDF file. However if utilizing a third-party PDF generation tool
such as PDF 995, the guides do not print to PDF) If the output of the Visio File is a printer or to a Web
Page, the Guides simply do not print and can simply be left in the Visio diagram. If, at any time, you do
not wish to see the Guides, you can simply go to the Visio View Menu and turn them off. They can also
be placed on a user-defined layer and have their visibility and their print capability controlled by the
layer settings.
A Visio diagram can have effectively an unlimited number of guides in a Visio diagram.

There are three types of Guides available in Visio: Horizontal Guides, Vertical Guides, and Guide Points.

To be able to access Guides, two settings must be properly configured in Visio. Rulers must be visible and Guides must be visible. Both of these options under Visio 2003 and 2007 are accessible from the Visio View Menu. Choose the View Menu in Visio and ensure that both the ✓ Rulers and ✓ Guide Menu Items are selected and checked. Under Visio 2010 go to the View Tab of the Ribbon, and in the Show Area, ensure that the ✓ Rulers and ✓ Guide check boxes are selected and checked.

**ADDING HORIZONTAL GUIDES**

To create a Horizontal Guide move the Mouse Cursor upward until it just touches the bottom edge of the Horizontal Ruler at the top edge of the drawing window. As the cursor touches the bottom edge of the Horizontal Ruler, the Mouse Cursor will change to a double-headed arrow. Pausing the Mouse Cursor at this point will display a screen tip reading: “Drag to add a horizontal guide. CTRL+drag to set the vertical ruler zero. Double-click to reset horizontal ruler zero to default.”.

Left-Click, Hold, and Drag Down to drag out a Horizontal Guide. Release at the point where the guide should be located. At any time the guide may be selected and drug up or down to relocate it.

At this point any SmartShape symbol may be selected and drag up or down to touch the Guide and will become Glued to the Guide. Any SmartShape symbol may be Glued to a Horizontal Guide based on the Top or Bottom Edge of the SmartShape symbol’s Bounding Box, or Glued to a Horizontal Guide based on the Vertical Middle of the Bounding Box.

**ADDING VERTICAL GUIDES**

To create a Vertical Guide move the Mouse Cursor leftward until it just touches the right edge of the Vertical Ruler at the left edge of the drawing window. As the cursor touches the right edge of the Vertical Ruler, the Mouse Cursor will change to a double-headed arrow. Pausing the Mouse Cursor at this point will display a screen tip reading: “Drag to add a vertical guide. CTRL+drag to set the vertical ruler zero. Double-click to reset vertical ruler zero to default.”.

Left-Click, Hold, and Drag Right to drag out a Vertical Guide. Release at the point where the guide should be located. At any time the guide may be selected and drug Left or Right to relocate it.

At this point any SmartShape symbol may be selected and drug left or right to touch the Guide and will become Glued to the Guide. Any SmartShape symbol may be Glued to a Vertical Guide based on the Left or Right Edge of the SmartShape symbol’s Bounding Box, or Glued to a Vertical Guide based on the Horizontal Center of the Bounding Box.

Any SmartShape symbol may simultaneously be Glued to BOTH a Horizontal Guide and a Vertical Guide at a point where the Guides Intersect.

**ADDING GUIDE POINTS**

A Guide Point is similar to a Horizontal or a Vertical Guide, with the same capabilities. The Guide Point, however, is a single point.

To create a Guide Point move the Mouse Cursor leftward and upward until it just touches the intersection of the Horizontal Ruler and the Vertical Ruler at the Upper-Left-Corner of the drawing window. As the cursor touches the center of the blue dashed “plus sign” at the intersection of the rulers, the Mouse Cursor will change to a four-headed arrow. Pausing the Mouse Cursor at this point will...
display a screen tip reading: “Drag to add a guide point. CTRL+drag to set both ruler zeros. Double-click to reset both ruler zeros to default.”.

Left-Click, Hold, and Drag Down and Right to drag out a Guide Point. Release at the point where the Guide Point should be located. At any time the Guide Point may be selected and drag Left, Right, Up, or Down to relocate it.

SmartShape symbols may be Glued to any Guide Point as needed.

**CROSS-FUNCTIONAL FLOW DIAGRAMS**

Cross-Functional Flow Diagrams, sometimes known as “Swimlane” Diagrams, are flow diagrams that isolate the individual process steps into functional bands which describes responsibility for that function. For example Billings might well be a function of the Finance Department, however the physical mailing of the invoices might fall under the jurisdiction of the Operations group.

To begin a Cross-Functional Diagram, select File ➤ New Flowchart ➤ Cross Functional Flowchart from the Visio File Menu.

**ADDING, DELETING, RESIZING, AND RELOCATING CROSS-FUNCTIONAL BANDS (Visio 2003 and Visio 2007)**

When the diagram is launched, a single page dialog will be displayed. This dialog will require two items of input:

1. Select whether the Cross-Functional Bands (“Swimlanes”) will be placed horizontally on a landscape mode page, or vertically on a Portrait mode page. For the purposes of example choose Horizontal.
2. Enter a value between 1 and 5 to determine the number of bands to be initially included in the diagram. Do not worry if you need more than five bands. The wizard limits the selection to five; however more can be added from a Visio Stencil at any time needed. For the purposes of example set the value to be five.

Click the OK Command Button to close the wizard and configure the diagram.

To add an additional band, simply drag a Functional Band Master SmartShape symbol from the Cross Functional Flowchart Shapes Horizontal Stencil and drag and drop the Master near the bottom of the diagram page. Note that the band will automatically reposition itself to add itself to the collection of bands on the page. Note also that the bottom edge of the band is at the exact bottom edge of the diagram page. This is less than desirable since the outer ¼ in around the page will not print on most laser printers.

To resize the collection of bands, select all of the bands by Left-Clicking on the Top-most band, holding down the Shift key and Left-Clicking on the remaining five bands. Once all of the bands are selected, choose View Size & Position Window from the Visio View Menu. This will display the Visio Size & Position Window. Note in the Window that the height of all six of the Functional Bands are shown as being 1.25 in. high. Change the value in the window to be exactly 1.00 inches high (1.00 in). Left-Click out of the window to affirm your changes and note that the bands are all now exactly one inch high.

To add an additional band, and to ensure that the new band is exactly the same size as the other six, Left-Click on the bottom-most band and then while holding down the Ctrl key on the keyboard, drag out
and downward to create a duplicate of the lowermost band. When you release, the new 7th band will be added to the collection of bands.

The Page may be resized and any band or bands may be resized to accommodate the required number of bands.

To delete a band, simply Left-Click to select the band and press the Delete key on the keyboard.

To reposition a band simply Left-Click and drag the band into its new position.

**ADDING, DELETING, RESIZING, AND RELOCATING CROSS-FUNCTIONAL BANDS (Visio 2010)**

When the diagram is launched, a new Cross-functional diagram will be generated with two Swimlanes already populated onto the page.

To add an additional band, go to the Cross-Functional Flowchart tab of the Ribbon and Left-Click on the Swimlane Item of the Insert Area. The new Swimlane will automatically be added. Additionally, you can left-click to select the lowermost Swimlane, and Ctrl+Drag out a new Swimlane (which will be a copy or clone of the previous), and locate it below the previous Swimlane.

To resize the collection of bands, select all of the bands by Left-Clicking on the Top-most band, holding down the Shift key and Left-Clicking on the remaining five bands. Once all of the bands are selected, choose go to the View Tab on the Ribbon, go to the Task Panes item in the Show Area, and using the drop-down, select the Size & Position item. This will display the Visio Size & Position Window. Note in the Window that the height of all six of the Functional Bands are shown as being 1.25 in. high. Change the value in the window to be exactly 1.00 inches high (1.00 in). Left-Click out of the window to affirm your changes and note that the bands are all now exactly one inch high.

The Page may be resized and any band or bands may be resized to accommodate the required number of bands.

To delete a band, simply Left-Click to select the band and press the Delete key on the keyboard.

To reposition a band simply Left-Click and drag the band into its new position.

**PLACING FLOWCHART SmartShape symbols IN FUNCTIONAL BANDS**

To place a Flowchart SmartShape symbol in a Functional band SmartShape symbol, simply drag the desired Master Flowchart SmartShape symbol from the Basic Flowchart Shapes Stencil onto the Visio Diagram Page, placing it in the desired Swimlane. In a best practice scenario DO NOT YET connect the Flowchart Shapes. Get the logic correct for placement, text added, etc. PRIOR to connecting the Flowchart symbols with Dynamic Connectors.

Note that under Visio 2010, each Swimlane is, in fact, a new Visio Object Type called a Container. Items placed in a Container under Visio 2010 stay within that Container whenever that container is relocated.

**CONNECTING SmartShape symbols IN AND ACROSS FUNCTIONAL BANDS**

Once the logic is correct, then, go to the Visio Standard Toolbar and find and select the Connector Tool. Moving your mouse cursor over a connection point on the Right side of the predecessor Flowchart SmartShape symbol, Left-Click, Hold and Drag your Mouse Cursor to the connection point at the Left side of the Successor Flowchart SmartShape symbol and release. This will ensure that the flow connections are placed in a fashion consistent with standard flowcharting techniques. Repeat this process for all other connections.
ADDING COLORED BACKGROUND TO FUNCTIONAL BANDS AND HEADERS

By default, none of the bands have any fill at all. Bands are certainly easier to read if each band has its own color, or at least the bands alternate in color. To add color to a band under Visio 2003 and Visio 2007, Left-Click on the header for the band (at the left or top of the band, dependent upon horizontal or vertical orientation). When the header is highlighted, go to the exact opposite end of the band and Left-Click on the edge of the band furthest from the header. Note that the entire band becomes selected with grey sizing handles. Choose Format ➤ Fill… from the Visio Format menu. Select an appropriate Fill color from the palette of colors and Left-Click the OK Command button to close the dialog and confirm your color choice.

To add color to a band under Visio 2010, go to the Cross-Functional Flowchart Tab of the Ribbon. Right-Click on the Header for the required Swimlane and select Format ➤ and uncheck the Allow Themes Checkbox. Next, on the Cross-Functional Flowchart Tab of the Ribbon, in the Design Area, use the Drop-down under the Style item to select the middle item in the second row. Next, Right-Click on the Swimlane Header and select Format ➤ Fill from the Context Menu. Choose a color from the palette and note that a lighter version of that color will be applied to the Swimlane while the full intensity color will be applied to the header itself.

TIMELINE DIAGRAMS

Visio Timeline Diagrams are the perfect method for conveying your Project-centric data in a clear, concise visual manner. Whereas many people who look at GANTT Charts and simply feel lost in the message, a Visio timeline easily tells the story of which events and intervals need to be accomplished on what date, and as an added benefit, they are capable of “drill in” to see the details at a more granular level.

To begin a new Timeline in Visio 2003 or 2007, choose File ➤ New ➤ Schedule ➤ Timeline from the Visio File menu. In Visio 2010, go to the Backstage area and select Schedule from the Template Categories. Select the Timeline item from the collection of Templates. Choose the units you desire then Left-click on the Create item.

ADDING A TOP-LEVEL TIMELINE

The first step in creating a Visio Timeline is to add the Top-Level Timeline to the Diagram Page. Select any of the five Timeline Master SmartShape symbols from the Timeline Shapes Stencil and drop it near the top of the Diagram Page, centered on the Page’s Width. The Configure Timeline Dialog will be displayed.

Choose both Starting and Ending Dates from the two lists, then set the Timeline Scale from the list below. Depending upon the scope of the Project, this Time Scale might be Years, Quarters of a Year, Months, Weeks, Days, yes... even Hours, Minutes or Seconds. Choose the granularity that makes sense for the overall project. Often Quarters or Months works best. When your choices have been made, Left-Click on the OK Command Button to confirm your choices and close the dialog.

ADDING MILESTONES TO TIMELINES

With the Top-Level Timeline in place, you may now place one or more Milestones on the Timeline. Depending upon the style of Timeline you chose, Drag a Milestone of a comparable style (if you chose a cylindrical Timeline, use a cylindrical milestone) and drop it quite literally anywhere along and on the face of the Timeline. When you drop the Milestone the Configure Milestone Dialog will be displayed. In the dialog, select the actual date for this particular milestone from the list. Give the Milestone a
Description. When the Milestone is configured, Left-Click the OK Command Button to confirm your choices and close the dialog. Repeat this process for every Top-Level Milestone you wish to declare.

**ADDING INTERVALS TO TIMELINES**

Similar to adding Milestones, add an Interval by dragging any compatible Interval SmartShape symbol from the Timeline Shapes Stencil onto the face of the Diagram Page. The Drop event for the Interval will display the Configure Interval dialog will be displayed.

Select a Start Date and an End Date, and provide a Description. When the Interval is configured, Left-Click the OK Command Button to confirm your choices and close the dialog. Repeat this process for every Top-Level Interval you wish to declare.

If the Interval SmartShape symbol is obscuring either the Breakdown Marker and/or individual Milestones, Right-Click on the Interval and choose Format  Fill… from the Interval SmartShape symbol’s context Menu. In the Fill dialog, set the transparency Slider Control to a level of about 30%. Left-Click the OK Command Button to confirm your choice and close the dialog. The Interval SmartShape symbol will now be semi-transparent allowing you to look through it to see the breakdown markers and milestones previously hidden behind the interval.

**ADDING TODAY MARKERS TO TIMELINES**

An interesting tracking SmartShape symbol is the Today marker SmartShape symbol. Drag the Today marker from the Stencil onto the Timeline. Note that it will “hop” into place, located at the point which represents Today on the Timeline. Each time you open the Diagram, the Today marker will adjust itself to show the current date in this Diagram.

**ADDING ELAPSED TIME INDICATORS TO TIMELINES**

Similar to the Today marker, the Elapsed Time marker, when dropped on the Timeline will start at the Beginning Date for the Timeline and stretch to the Right to show the Elapsed time until Today. Each time you open the Diagram, the Elapsed time marker will adjust itself to show the current date in this Diagram.

**CREATING EXPANDED TIMELINES**

Often you will want to look a particular portion of the Timeline in much greater detail. This is where the Expanded Timeline comes in to play. Drag an Expanded Timeline SmartShape symbol from the Stencil and drop it onto the Timeline. The Configure Timeline Dialog will be displayed.

Choose both Starting and Ending Dates from the two lists, then set the Timeline Scale from the list below. Depending upon the scope of the detail you are illustrating, this Time Scale might be Years, Quarters of a Year, Months, Weeks, Days, yes… even Hours, Minutes or Seconds. Choose the granularity that makes sense for the detailed “drill-in” you are creating for this project. When your choices have been made, Left-Click on the OK Command Button to confirm your choices and close the dialog.

Note that the new Timeline is a 1-D SmartShape symbol and both the BeginPoint and EndPoint are visible on the new Expanded Timeline. Drag these endpoints off the original Timeline to a location below the original timeline. Note the small yellow diamonds shown just below the original timeline. These control handles adjust the begin and end date of the expansion. Adjust these as required.

The Top-Level Time can have as many Expansions as you wish. Each of the Expansions can have as many Expansions as is required, etc., etc., etc. In this manner you can detail out every nuance of the project plan, adding more detail with each expansion.
**EXPORTING MILESTONES AND INTERVALS TO MICROSOFT OFFICE PROJECT 2007 or PROJECT 2010**

Once you have the Timeline and all of its inherent expansions properly configured, it would be truly beneficial to be able to use this timeline to generate an actual Microsoft Office Project 2007 Professional Project Plan (*.MPP). The only requirement is that BOTH Microsoft Office Visio 2007 Professional and Microsoft Office Project 2007 Professional be installed on your current desktop if utilizing the 2007 suite, or that BOTH Microsoft Office Visio 2010 Professional and Microsoft Office Project 2010 Professional be installed on your current desktop if utilizing the 2010 suite.

The Visio Timeline Solution can export both the complete collection of Milestones and Intervals from the Visio diagram and generate a NEW Project .MPP file with those Milestones and Intervals already in place. Note that ONLY Milestones and Intervals are passed. No dependencies or resources are generated in the process.

To perform the export, first Left-Click on the Top Level Timeline, then, if using Visio 2007, choose Timeline ▶ Export Timeline Data… from the Visio Timeline menu. If using Visio 2010, go to the Timeline Tab on the Visio Ribbon, and from the Timeline area, Left-Click to choose the Export Data Item. You will then be prompted if you wish to export all of the Milestones and Intervals on the Expanded Timelines as well. Left-Click the Yes Command Button to confirm your desire to export ALL items. You will then be presented with a Windows File Dialog, allowing you to set a location and file name for the export to the .MPP format. Choose the location and filename that best suits you. Left Click the Save Command Button to confirm your choices, close the dialog, and create the .MPP file. You will be shown a confirmation Message Box to let you know that the Project file has been successfully created. Left-Click the OK Command Button to close the Message Box.

**IMPORTING MILESTONES AND INTERVALS FROM MICROSOFT OFFICE PROJECT 2007 or PROJECT 2010**

Importing Milestones and Intervals from Microsoft Office Project 2007 Professional or Project 2010 is equally as easy as exporting the data. Again, the only requirement is that BOTH Microsoft Office Visio 2007 Professional and Microsoft Office Project 2007 Professional be installed on your current desktop if utilizing the 2007 suite, or that BOTH Microsoft Office Visio 2010 Professional and Microsoft Office Project 2010 Professional be installed on your current desktop if utilizing the 2010 suite.

Begin by creating a new blank Timeline Diagram in Visio 2007 Professional or Visio 2010 Professional. Next, if using Visio 2007 choose Timeline ▶ Import Timeline Data… from the Visio Timeline menu. If using Visio 2010, go to the Timeline Tab on the Visio Ribbon, and from the Timeline area, Left-Click to choose the Import Data Item. This action will display the Import Timeline Wizard.

In the first screen of the Wizard, Left-Click the Browse... Command Button to browse to and select the desired Microsoft Office Project 2007 Professional .MPP file. When located and selected in the Windows File Dialog, Left-Click on the Open Command Button to confirm your choice of .MPP file and return you to the Wizard. In the Wizard, Left-Click the Next > Command Button to advance to the second screen of the Wizard.

In the Second Screen of the Wizard, Left-Click to choose the level of detail you wish to import. Choose one from: All, Top Level Tasks Only, Milestones Only, Summary Tasks Only, or Top Level Tasks and Milestones. When your choice has been made, in the Wizard, Left-Click the Next > Command Button to advance to the third screen of the Wizard.
In the Third Screen of the Wizard, select the style of Timeline, Milestone, and Interval that you wish to use to create the new Timeline from the data in the Project file. An Advanced Command Button is available to assist in setting time formats for all elements of the Timeline as well. When your choices have been made, in the Wizard, Left-Click the Next > Command Button to advance to the fourth screen of the Wizard.

In the Fourth (and Last) Screen of the Wizard, review the set of options you have chosen. When satisfied, Left-Click the Finish Command Button to confirm your choices, close the Wizard, and generate the Visio Timeline from the Microsoft Project Data.

Notice that this will create the Top Level Timeline Only and that there will be text collisions with the complete set of Milestones and Intervals all shown on the Top Level Timeline. By use of Guides, Expanded Timelines and some formatting, you will have a fine, eminently readable diagram in just a few minutes.

BRAINSTORMING DIAGRAMS

Visio Brainstorming diagrams are one of many diagram types that fall into the classification of Hierarchal Diagrams. These diagrams are highly flexible and easy to create. They convey any sort of hierarchal information in a visual manner. Begin creating a new Brainstorming Diagram under Visio 2007 by choosing File ➤ New ➤ Business ➤ Brainstorming Diagram from the Visio File menu. If using Visio 2010, in Visio 2010, go to the Backstage area and select Business from the Template Categories. Select the Brainstorming Diagram item from the collection of Templates. Choose the units you desire then Left-click on the Create item.

CREATING BRAINSTORMING DIAGRAM HEIRARCHIES

When the Brainstorming Diagram is started, you will be confronted with the typical Visio environment; Stencils to the Left, and the Diagramming Surface filling the remainder of the Visio environment. Additionally, in the Lower-Left of the Diagramming Surface you will see a new dock-able Window, which is the Outline Window. During the creation of the Brainstorming hierarchal diagram, you can work interactively between the Diagramming Surface and the Outline Window.

To begin, drag a Main topic Master SmartShape symbol out onto the Diagram surface. You will want to change the text on the face of this SmartShape symbol to something that makes sense for your business. For the purpose of this example, type in “MacRumbles Quick Eats”. Notice that in the Outline Window, Visio is creating the hierarchy for this diagram as you progress.

ADDING A SUBTOPIC

To add a Sub-Topic under this Top Level Topic, Right-Click and choose Add Subtopic from the context menu of the MacRumbles Quick Eats Top Level SmartShape symbol. A new subtopic item will be created ready to have the text modified to suit your needs. Enter “Breakfast” as the Text for this new Sub-Topic SmartShape symbol. Note that the Outline Window has updated to track the modifications you have made to this Sub-Topic. Under Visio 2010, you can alternately, go to the Brainstorming Tab of the Ribbon, and Left-Click on the Subtopic Item on the Add Topics Area.

ADDING MULTIPLE SUBTOPICS

To add multiple Sub-Topics at the same time, Right-Click on the desired SmartShape symbol (in this case the MacRumbles Quick Eats) and choose Add Multiple Subtopics... from the context menu. ( Under Visio
2010 you can alternately go to the Brainstorming Tab of the Ribbon, and select the Multiple Subtopics item on the Add Topics Area). An Add Multiple Topics Dialog will be displayed. Enter each additional Sub-Topic into this dialog, remembering to press the Enter Key between each entry. In the Case of this example, enter the following three items: Lunch, Dinner, and Late Night Snack. Remember to press the Enter key between each of the items you enter. When complete, Left-Click the OK Command Button to confirm your entries, close the dialog, and add the Sub-Topics to the parent SmartShape symbol.

Right-Click on the Lunch SmartShape symbol and choose Add Multiple Subtopics... from the context menu. Under the Lunch item you want to add the following (just as you did above): Beef Burger, Chicken Sandwich, and Hot Dog. Remember to press the Enter key between each of the items you enter. When complete, Left-Click the OK Command Button to confirm your entries, close the dialog, and add the Sub-Topics to the parent SmartShape symbol.

**RESTRUCTURING TOPICS AND SUBTOPICS**

Presuming that Hot Dogs are only available at Dinner, rather than having to delete the entry from the Lunch SmartShape, or Disconnect, Unglue, re-Glue and modify the Hot Dog Menu item, simply move your Mouse Cursor over the Hot Dog Item in the Outline Window, and Left-Click, Drag and Release over the Dinner entry. Notice how BOTH the outline and the Diagram have been properly updated.

**APPLYING BRAINSTORMING STYLES TO DIAGRAMS**

When the logic for the Brainstorming Hierarchical Diagram is all in place and correct, and only AFTER the logic is all in place, it is time to format the diagram to a visual style consistent with the type of hierarchical diagram you wish to see. The reason that it is recommended to format after the logic is in place is that if you format too early and make more additions, subtractions, alterations to the nodes of the hierarchy, you will simply need to re-format after each change. Therefore formatting once after the logic is correct is actually much faster.

To apply a Brainstorming style to the diagram under Visio 2007, choose Brainstorming  Brainstorming Style... from the Visio Brainstorming menu. Under Visio 2010, go to the Brainstorming Tab, and in the Manage Area, select the Diagram Style Item. This action will display the Brainstorming Style Dialog.

In the Brainstorming Style Dialog, choose, by Left-Clicking on, any of the Formatting Style items at the left of the dialog. The options are: (1) Simple [Default], (2) Billowing, (3) Boxy, (4) Elliptical, (5) Mosaic 1, (6) Mosaic 2, and (7) Starburst. When you are satisfied with your choice of Brainstorming Style, Left-Click on the OK Command Button to confirm your choice, close the dialog and apply the Brainstorming Style to your diagram.

**APPLYING BRAINSTORMING LAYOUTS TO DIAGRAMS**

After the Style has been set and confirmed, the final formatting step is to apply the layout direction to the diagram. By default, Brainstorming Diagrams start in the center and work outward. However you have several other layout choices.

To select a layout choice under Visio 2007, begin by choosing Brainstorming  Layout... from the Visio Brainstorming menu. This action will display the Layout Dialog. Under Visio 2010, go to the Brainstorming Tab, and in the Arrange Area, select the Layout Item.

In the Layout Dialog, Left-Click to choose one of the five layout types: (1) Default, (2) Left to Right, (3) Right to Left, (4) Top to Bottom, and (5) Bottom to Top.

In the Layout Dialog, Left-Click to choose one of two Connector Visual Formats: (1) Curved, and (2) Straight.
When you are satisfied with your choice of Brainstorming Layout, Left-Click on the OK Command Button to confirm your choices, close the dialog and apply the Brainstorming Layout to your diagram.

**EXPORTING BRAINSTORMING DATA TO MICROSOFT OFFICE WORD 2007 or 2010**

Now that the Brainstorming Diagram is complete, it would be highly productive if the data from this diagram could be shared with other Microsoft Office applications.

Begin the export in Visio 2007, by choosing Brainstorming ➤ Export Data ➤ To Microsoft Office Word..., or Brainstorming ➤ Export Data ➤ To Microsoft Office Excel..., or Brainstorming ➤ Export Data ➤ To XML... from the Visio Brainstorming Menu. In Visio 2010, go to the Brainstorming Tab of the Ribbon, and in the Manage Area, select the Drop-down for the Export Data item and choose “To Microsoft Word...”, “To Microsoft Excel...”, or “To XML”. In the case of this example, the export will be to Microsoft Office Word. Choosing this option will display the Windows File Save dialog. This dialog will allow you to set a location for the intermediate XML file which will be used to generate the Microsoft Office Word Document. In the File ➤ Save Dialog, browse to and select a directory for the XML file and supply a name for the XML file. When you have chosen the intermediate file, Left-Click the Save Command Button to confirm your choice, close the dialog and generate the XML file.

When this action is complete, Visio will launch Microsoft Office Word and generate the Word Document including all of the data from the Visio Diagram. Note that the Top Level is formatted in Word’s Heading 1 format, the next tier in the Visio hierarchy is formatted in Word in the Heading 2 format, etc., etc., etc.

**EXPORTING BRAINSTORMING DATA TO MICROSOFT OFFICE EXCEL 2007 or 2010**

Choosing the Excel option will display the Windows File Save dialog. This dialog will allow you to set a location for the intermediate XML file which will be used to generate the Microsoft Office Excel Document. In the File ➤ Save Dialog, browse to and select a directory for the XML file and supply a name for the XML file. When you have chosen the intermediate file, Left-Click the Save Command Button to confirm your choice, close the dialog and generate the XML file.

When this action is complete, Visio will launch Microsoft Office Excel and generate the Excel Workbook including all of the data from the Visio Diagram. Note that the Column A contains the Hierarchy listed as T1, T1.1, T1.2, T1.2.1, etc. Note that Column B contains the text displayed on the face of each SmartShape symbol as text in the cells of Rows 1 through (n).

**EXPORTING BRAINSTORMING DATA TO XML**

Choosing the XML option will display the Windows File Save dialog. This dialog will allow you to set a location for the XML file. In the File ➤ Save Dialog, browse to and select a directory for the XML file and supply a name for the XML file. When you have chosen the file, Left-Click the Save Command Button to confirm your choice, close the dialog and generate the XML file.

When this action is complete, Visio will display a Message Box to inform you that the Export was successful. Left-Click the OK Command Button to close the Message Box.

The Resulting XML file will look similar to the following:

```xml
<?xml version="1.0" encoding="UTF-8" ?>
<bs:Brainstorm
  <bs:topic bs:TopicID="T1">
```

```xml
```
MacRumbles Quick Eats

- Breakfast
  - Beef Burger
  - Chicken Sandwich

- Lunch
  - Hot Dog

- Dinner
  - Late Night Snack

---

**IMPORTING BRAINSTORMING DATA FROM MICROSOFT OFFICE WORD 2007 or 2010**

It is also possible to generate a Visio Brainstorming Hierarchal diagram from data contained in Microsoft Word. To accomplish this, ensure that the document in Microsoft Word has been formatted utilizing Heading 1, Heading 2, Heading 3, etc. When the Microsoft Word Document is ready, and the Word document has been properly named, saved in Word XML format (*.xml), and closed, return to Visio, create a new Brainstorming diagram, and choose from Visio 2007, Brainstorming ➤ Import Data... from the Visio Brainstorming menu, or from Visio 2010, from the Brainstorming Tab of the Ribbon, in the Manage area, Left-click on the Import Data item.

This action will display the Windows File Open Dialog. In this dialog, browse to the Word XML document, select the .XML file, and then Left-Click on the Open Command Button to confirm your choice, close the dialog and generate the Visio diagram from the XML data.
MANUALLY CREATING AN ORGANIZATIONAL [HIERARCHAL] DIAGRAM

There are essentially two methods of starting a new Organizational Diagram within Visio 2007. The first involves beginning the diagram from the new Visio 2007 “Getting Started” screen. Each time the user double-clicks on a Visio shortcut on the user’s desktop, or chooses Microsoft Office → Microsoft Office Visio 2007 from the Microsoft Windows XP or Microsoft Windows Vista Start Menu, the application Visio launches and the user is presented, by default (unless the user has opted not to show the Getting Started screen from the Tools → Options... dialog), with the Getting Started Screen.

Getting Started Methodology (Visio 2007)

While the Getting Started Screen is active in Visio 2007 (both Standard and Professional editions), look at the Template Categories at the Left Side of the Getting Started set of Task Panes. Left-Click to select the Category listed as Business.

This action will display the Business Category and its store of available Visio Business Templates.

Left-Click on the Organization Chart Icon in either the Featured Templates area or the Other Templates area of the Business Category Page of the Getting Started Task Area. Next, Left-Click to choose either the US units or the Metric Radio Button, depending on the desired target output. Finally, Left-Click on the Create Command Button to confirm the choices and create the new blank Organizational Diagram.

Getting Started Methodology (Visio 2010)

In the Backstage Area of Visio 2010 (both Standard and Professional editions), look at the Template Categories. Left-Click to select the Category listed as Business.

This action will display the Business Category and its store of available Visio Business Templates.

Left-Click on the Organization Chart Icon. Next, Left-Click to choose either the US units or the Metric Radio Button, depending on the desired target output. Finally, Left-Click on the Create Item to confirm the choices and create the new blank Organizational Diagram.

File Menu Methodology (Visio 2007)

Whether or not the Getting Started Screen is active in Visio 2007 (both Standard and Professional editions), Left-Click on the File Menu in the Visio 2007 Menu Sets at the top of the Visio environment. Choose File → New → Business → Organization Chart (US units) from the Visio File Menu.

Either the Getting Started methodology, or the File → New methodology will result in the creation of a new blank Organizational Diagram.

Adding the Executive

The first step in actually manually creating a Visio Organizational Diagram is to add the absolute Top Level person to be shown on the diagram. This is generally the CEO, the President, or other Top Executive. To add this person to the diagram, Left-Click, (Hold the Left Mouse Button Down) Drag, and
Drop the Executive Master SmartShape symbol found on the Organization Chart Shapes Stencil. Drop the instance at a point near the top of the diagram Page and centered on the diagram Page.

When this action is complete, the Executive SmartShape symbol will be displayed on the page, and (by default unless the feature is turned off) a small assistance dialog will be displayed informing you as to the proper methodology for creating the connected hierarchy in the Organizational Diagram.

The message states “To connect shapes, drop a shape on top of the superior shape.” In other words, to add a Manager reporting to the Executive, simply Left-Click, (Hold the Left Mouse Button Down) Drag, and Drop the Manager Master SmartShape symbol found on the Organization Chart Shapes Stencil directly on top of the Executive SmartShape symbol. Visio will automatically take care of providing a Dynamic Connector SmartShape symbol and gluing the Beginning of the Dynamic Connector SmartShape symbol, utilizing Dynamic Glue, to the Executive SmartShape symbol, and gluing the Ending of the Dynamic Connector SmartShape symbol, utilizing Dynamic Glue, to the Manager SmartShape symbol.

To close this dialog, Left-Click the OK Command Button. To ensure that it does not pop up again, Left-Click to Check the Don’t show this message again. Check Box prior to Left-Clicking on the OK Command Button.

**ADDING SUBORDINATES**

Once an Executive has been added to the Diagram, additional subordinates may be added by dragging them from the stencil and dropping them on the Organizational Diagram SmartShape symbol representing their superior. As stated before, simply Left-Click, (Hold the Left Mouse Button Down) Drag, and Drop the Manager Master SmartShape symbol found on the Organization Chart Shapes Stencil directly on top of the Executive SmartShape symbol. Visio will automatically take care of providing a Dynamic Connector SmartShape symbol and gluing the Beginning of the Dynamic Connector SmartShape symbol, utilizing Dynamic Glue, to the Executive SmartShape symbol, and gluing the Ending of the Dynamic Connector SmartShape symbol, utilizing Dynamic Glue, to the Manager SmartShape symbol. This process may be repeated for each additional Manager reporting directly to the Executive.

**Adding One Subordinate at a Time**

To add one subordinate SmartShape symbol at a time to the diagram, follow the procedure detailed above, dropping Manager SmartShape Symbols on top of Executive SmartShape symbols, dropping Position SmartShape Symbols on top of Manager SmartShape symbols, dropping Vacancy SmartShape symbols, Consultant SmartShape symbols, and Assistant SmartShape symbols as necessary to describe the structure of the Organization being documented.

Note that as each SmartShape symbol is added to the Organizational Diagram, each SmartShape symbol displays the text “Name” and “Title” on the face of the particular symbol. This text may be easily replaced by editing the Shape Data for that given SmartShape symbol. To edit the Shape Data for any given SmartShape symbol, Right-Click on the SmartShape symbol and select Properties from the SmartShape symbol’s context menu. This action will cause the Shape Data dialog to be displayed.

Left-Click into each field that requires a new value to be set. Edit the text as necessary.

When all edits have been completed, Left-Click the OK Command Button to confirm the changes and close the dialog. The SmartShape symbol’s Text will be updated to reflect these changes.

Keep in mind that by default, only the Name and Title fields are visible on the face of the SmartShape symbol.
Adding Three Subordinates at the Same Time

If, for any reason, exactly three Position subordinates report to the same singular Manager, the process of adding the three Position SmartShape symbols may be shortened by selecting the Three positions Master SmartShape symbol from the Organization Chart Shapes stencil, Left-Click, (Hold the Left Mouse Button Down) Drag, and Drop the Three positions Master SmartShape symbol directly on top of the Manager SmartShape symbol. Visio will automatically take care of providing a Dynamic Connector SmartShape symbol for each Position SmartShape symbol and glue the Beginning of the Dynamic Connector SmartShape symbol, utilizing Dynamic Glue, to the Manager SmartShape symbol, and glue the Ending of each Dynamic Connector SmartShape symbol, utilizing Dynamic Glue, to the individual Position SmartShape symbols. The resultant three Position SmartShape symbols will be evenly spaced below the Manager SmartShape symbol.

Adding Multiple Subordinates at the Same Time

A more generic, and perhaps, more flexible method for adding multiple subordinates under a superior is to make use of the Multiple shapes Visio SmartShape symbol found on the Organization Chart Shapes stencil. Left-Click, (Hold the Left Mouse Button Down) Drag, and Drop the Multiple shapes Master SmartShape symbol found on the Organization Chart Shapes Stencil directly on top of the desired superior SmartShape symbol. Visio will not actually place a new SmartShape symbol, but, rather, will trigger the execution of some Automation Code which will display a small dialog. This dialog allows you to (a) specify the number of subordinate SmartShape symbols to be added under the superior SmartShape symbol selected by the Drop action, and (b) specify which Master SmartShape symbol will be used to create and glue the multiple subordinate SmartShape symbols.

Visio will automatically take care of providing a Dynamic Connector SmartShape symbol and gluing the Beginning of the Dynamic Connector SmartShape symbol, utilizing Dynamic Glue, to the superior SmartShape symbol, and gluing the Ending of the Dynamic Connector SmartShape symbol, utilizing Dynamic Glue, to each of the subordinate SmartShape symbols. This process may be repeated for each additional superior SmartShape symbol requiring multiple subordinate SmartShape symbols.

Adding Staff Members

An additional SmartShape symbol used in Organizational Diagrams is the Staff SmartShape symbol. The Staff SmartShape symbol is used similarly to any other Organization Chart SmartShape symbol. Its primary difference is that the Staff SmartShape symbol is not confined within a rectangle.

To add Staff SmartShape symbols subordinate to a Position SmartShape symbol, Left-Click, (Hold the Left Mouse Button Down) Drag, and Drop the Staff Master SmartShape symbol found on the Organization Chart Shapes Stencil directly on top of the Position SmartShape symbol. Visio will automatically take care of providing a Dynamic Connector SmartShape symbol and gluing the Beginning of the Dynamic Connector SmartShape symbol, utilizing Dynamic Glue, to the Position SmartShape symbol, and gluing the Ending of the Dynamic Connector SmartShape symbol, utilizing Dynamic Glue, to the Staff SmartShape symbol. This process may be repeated for each additional Staff member reporting directly to the Position member.

ADDING TEAM FRAMES

A Team Frame SmartShape symbol is used to encompass all members of a designated group that work together, obviously, as a team. This SmartShape Symbol may be dropped, then relocated, and resized.
utilizing the SmartShape symbol’s sizing handles to adjust its size to fit around the team in question. The Text of the Team Frame SmartShape symbol may be edited to provide a proper label for the subject team.

**ADDING “DOTTED-LINE” RELATIONSHIPS**

The structure of the Visio 2007 Organization Charting Solution is very rigid and works with the following logic. Any Individual in an Organization may have as many individuals reporting to him or her as desired, however each individual may ONLY report to one superior person. In other words, One-to-Many going DOWN the hierarchy, but One-to-One going UP the hierarchy. Because of this limitation in logic, Visio provides a specialized Dynamic Connector SmartShape symbol called a Dotted-line report SmartShape symbol.

By dragging and dropping a Dotted-line report SmartShape symbol onto the Organizational Diagram Page and subsequently gluing the beginning and end of the Dotted-line report SmartShape symbol to the appropriate Superior and Subordinate SmartShape symbols, the Dotted-line report SmartShape symbol can be used to visually indicate the “Dotted Line”, “Alternate”, or “Secondary” reporting relationship required in some Organizations. The Process is simply to Left-Click, (Hold the Left Mouse Button Down) Drag, and Drop the Dotted-line report Master SmartShape symbol found on the Organization Chart Shapes Stencil onto the Visio Diagram Page. Next drag the Begin Point or End Point of the Dotted-line report SmartShape symbol to the required Connection Point on the Superior or Subordinate SmartShape symbol to establish the necessary glue. Keep in mind that this is totally a manual process, and should the diagram need to be recreated, these Dotted-line report SmartShape symbols would need to be manually laid in again by the creator of the new or updated diagram.

**CREATING SYNCHRONISED COPIES TO ADDITIONAL PAGES**

With large organizations, there is quite literally no way that all of the Organizational Member SmartShape symbols will fit on a standard 8.5”X11” or A4 sheet of paper. Therefore it is desirable for each Manager or Superior and their collection of subordinates to be displayed on their own page and have a visual reference to the team shown on the original page. This ability to segregate teams onto their own pages and yet still keep any changes synchronized between the “roll-up” page and the “team page” is native behavior to the Visio Organizational Charting solution.

Begin by Right-Clicking on the particular SmartShape symbol representing the head of the group to be placed on their own page and choose Create Synchronized Copy... from the context menu.

This action will display the Create Synchronized Copy dialog. By Default, the selection of Create a synchronized copy on New page is selected. Since the diagram thus far only has one page, the first page, established within it, this is the logical choice. If the diagram already had multiple pages in it, you would be free to select any existing page to create the synchronized copy and duplicate the team to that page. Notice, also, the check box for Hide subordinates on original page. This check box should be clicked and checked to ensure that the team is “rolled up” under this leader as displayed on the original first page.

When the OK Command Button is Left-Clicked, Visio confirms the action request, closes the dialog, rolls the team up on the original page, creates a new page, and displays the team on the new page.

By clicking on the Page-1 Page tab at the bottom of the diagramming window, you return to Page-1 and note that the team is now displayed as “rolled up” on the original page. This is designated by the illustration of the “stack” of Position SmartShape symbols, actually just a modification of the singular lead SmartShape symbol, on the page.
UNDERSTANDING SYNCHRONIZED COPIES

Many times users of Visio diagrams tend to think of the diagrams as static images, as if they were printed on a sheet of paper. However, while in the Visio environment, the diagrams are actually vibrant, alive, interactive documents. Note also that at any time the viewer of the diagram can expand or collapse the visualization of any team within the Visio Organizational Diagram.

**Expanding Subordinates**

To expand Subordinates under a superior, simply Right-Click on the superior SmartShape symbol and choose Expand Subordinates. Alternately, Left-Click to select the desired superior SmartShape symbol, and from the Visio Organization Chart menu, choose Organization Chart ➤ Show Subordinates.

**Collapsing Subordinates**

To collapse Subordinates under a superior, simply Right-Click on the superior SmartShape symbol and choose Hide Subordinates. Alternately, Left-Click to select the desired superior SmartShape symbol, and from the Visio Organization Chart menu, choose Organization Chart ➤ Hide Subordinates.

**Adding Divider Lines in Organizational SmartShape Symbols**

By default the Name of the person and their title are shown stacked directly on top of each other on the face of the SmartShape symbol. This can make it more difficult to read in a situation where there are hundreds of employees in the organization. Visio provides a mechanism for adding or removing a dividing line between the Name and the Title on an Organizational Charting SmartShape symbol.

To add a Divider Line between the Name and Title of an Organizational Charting SmartShape symbol, Right-Click on the SmartShape symbol and choose Show Divider Line from the Context Menu.

To remove a Divider Line between the Name and Title of an Organizational Charting SmartShape symbol, Right-Click on the SmartShape symbol and choose Hide Divider Line from the Context Menu.

**CREATING HYPERLINKS BETWEEN PAGES AND SmartShape symbols**

While it is not difficult to traverse between the top-level page and a subordinate detail page utilizing the page tabs at the bottom of the diagramming area, it would be beneficial and far more productive to provide a navigational shortcut from the SmartShape symbol on the original page to the details for that individual and his or her team. This can be accomplished one or both of two methods; hyperlinks and double-click actions. This section will step you through both of these methods.

The First method is establishing a hyperlink. Left-Click, to select, the SmartShape symbol to be used as the starting point of the hyperlink. From the Visio Insert Menu, choose Insert Hyperlinks…

This action will display the Hyperlinks dialog. Left-Click on the Browse... Command Button directly across from the Sub-address Text Box. In the listing choose “Page-2” as the target of the hyperlink (remember that in this case the expanded team resides on Page-2 of the diagram). Fill in the text for the verbiage for the hyperlink in the Description Text Box. In this case you might add the text “European Sales”.

Left-Click the OK Command Button to confirm the request to create a Hyperlink, close the dialog and complete the action.
The Second method is establishing a Double-Click action so that when the viewer of the diagram uses the Left Mouse button and Double-Clicks on the face of the, for example, Director of European Sales SmartShape symbol, the user will jump directly to the expanded team on Page-2. Left-Click, to select, the SmartShape symbol to be used as the source for the Double-Click action. From the Visio Format Menu, choose Insert Behavior...

This action will cause the Behavior dialog to display. In the Behavior dialog, Left-Click on the Double-Click tab at the top of the dialog. On the Double-Click tab look toward the very bottom of the dialog and locate the Go to page Radio Button. Left-Click to select the Go to page Radio Button and use the drop-down listing to select the Page-2 item. When these tasks have been completed, Left-Click the OK Command button to confirm the choices, close the dialog and complete the creation of the double-click action for this SmartShape symbol.

After this action has been completed, at any future time the user can either Right-Click and select the “European Sales” hyperlink, or simply use the Left Mouse Button and Double-Click to navigate to the detail page (in this case Page-2) for that director’s team.

In best practice, the same hyperlinks, behaviors, and actions would be established on the Page-2 representation of the Director’s SmartShape symbol to create Hyperlinks and Double-Click actions to return to the original page (in this case Page-1).

**USING THE ORGANIZATIONAL CHART WIZARD TO CREATE DIAGRAMS FROM EXCEL DATA**

There are actually two parallel methodologies for beginning the creating a new Organizational Diagram utilizing the Organization Chart Wizard. Like creating a new Organizational Diagram manually, the process can be instigated by either selecting from the Getting Started Task Pane, or from the Visio File menu.

**Getting Started Methodology (Visio 2007)**

While the Getting Started Screen is active in Visio 2007 (both Standard and Professional editions), look at the Template Categories at the Left Side of the Getting Started set of Task Panes. Left-Click to select the Category listed as Business. This action will display the Business Category and its store of available Visio Business Templates.

Left-Click on the Organization Chart Wizard Icon in either the Featured Templates area or the Other Templates area of the Business Category Page of the Getting Started Task Area. Next, Left-Click to choose either the US units or the Metric Radio Button, depending on the desired target output. Finally, Left-Click on the Create Command Button to confirm the choices and create the new blank Organizational Diagram. This action will also, as soon as the Organization Chart Diagram environment is ready, display the first screen of the Organization Chart Wizard.

**Getting Started Methodology (Visio 2010)**

In the Backstage Area of Visio 2010 (both Standard and Professional editions), look at the Template Categories. Left-Click to select the Category listed as Business.

This action will display the Business Category and its store of available Visio Business Templates.

Left-Click on the Organization Chart Wizard Icon. Next, Left-Click to choose either the US units or the Metric Radio Button, depending on the desired target output. Finally, Left-Click on the Create Item to confirm the choices and create the new blank Organizational Diagram.
File Menu Methodology (Visio 2007)

Whether or not the Getting Started Screen is active in Visio 2007 (both Standard and Professional editions), Left-Click on the File Menu in the Visio 2007 Menu Sets at the top of the Visio environment. Choose File ➤ New ➤ Business ➤ Organization Chart Wizard (US units) from the Visio File Menu.

When a new Organizational Diagram is begun using the Organization Chart Template (and NOT the Organization Chart Wizard Template), or if the creator of the Organization Chart opted to cancel out of the Wizard (having based the diagram on the Organization Chart Wizard Template), the user still has the ability to launch and display the opening screen of the Organization Chart Wizard by choosing Organization Chart ➤ Import Organization Data… from the Visio Organization Chart menu.

NOTE: At any time, from within the Organization Chart Diagram, either under Visio 2007 or 2010, you can opt to choose the item “Import Organizational Data” (2007) or “Import” in the Organization Data Area of the Org Chart Tab of the Ribbon. This action will launch the Org Chart Wizard. Because the Wizard can be launched at any time, it is HIGHLY recommended that you DO NOT use the Org Chart Wizard Template, as this will launch the wizard immediately upon creating the diagram. This will result in a diagram with no background pages. You options would be to add a separate back to each and every foreground page, or manually create a background page and then edit the page properties of each and every foreground page to assign them to the new background page. This results in wasted time and file space. The recommendation is to ALWAYS use the Organizational Chart Template and NOT the Wizard. Once you have created the desired background page, you may then launch the Wizard and continue on as usual. When the Wizard has run to completion, you will automatically have only one background page, and all newly created foreground pages will be assigned to that background page.

The Wizard

Any of the above actions will display the first screen of the Organization Chart Wizard.

The first screen of the Organization Chart Wizard prompts the creator to answer one question. “I want to create my organization chart from:”. The creator can opt to either create the Organizational Diagram from “information that’s already stored in a file or database”, or “Information that I enter using the wizard”.

In the case of this example, the creator will opt to utilize an Excel Spreadsheet containing the organizational structure. The structure of this spreadsheet will be discussed shortly.

From Data Stored in an External Data Source

The first option, From data stored in an external data source, will later prompt the creator to select a particular data file.

From Data Manually Entered in the Wizard

The second option, From data manually entered in the wizard, will solicit the creator to either open Microsoft Office Excel (to create a spreadsheet of data), open Windows Notepad (to create a deliminated text file), or browse for a file of either of these two types. The creator will then enter the data into one of these two formats, save and close the newly created data source file, then return to the wizard.
Left-Click the Next > Command Button to advance to the Second Screen of the Organization Chart Wizard.

The second screen then asks the creator to select the type of data source which will be used to import in the structure of the organization in question.

These data sources can be any of the following:

- A Microsoft Exchange Server directory
- A Text file (in comma, space, or character delimited format)
- An OrgPlus file (which has already been converted to text format and saved as such)
- A Microsoft Office Excel Workbook spreadsheet
- Any ODBC-compliant data source

**Data Sources**

A Microsoft Exchange Server directory

A Microsoft Exchange Server directory may be utilized as a valid data source. However, the Organization Chart Wizard needs to have two discrete fields of information to properly establish the hierarchy of the organization. These fields equate to (a) “Who am I”, and (b) “Who do I report to”. Many implementations of Exchange Server have the employee’s name, and their E-mail alias, and possibly their telephone extension and/or office/cubicle number, however, they rarely seem to have the Manager’s name listed within the Exchange Server directory.

The creator can work with the Exchange administrator to add this vital field, or opt to utilize another data source type.

A Text file (cdf, sdf, or chdf-delimited file)

A simple text file can be utilized to hold the source data. This text file can be either Comma, Space, or Character delimited. The structure of these files would be similar to the examples below:

**Comma Delimited**

Name, Title, Manager, Department, Telephone, E-mail, Master_Shape, Office Number

Jossef Goldberg, President & CEO, Office of the President, 555-0100, jossef@championzone.net, 17102

Suzan Fine, Executive Assistant, Jossef Goldberg, Office of the President, 555-0101, susan@championzone.net, Assistant, 17104

Clair Hector, COO, Jossef Goldberg, Operations, 555-0102, clair@championzone.net, 17106

**Space Delimited**

Name Title Manager Department Telephone E-mail Master_Shape Office Number

Jossef Goldberg President & CEO Office of the President 555-0100 jossef@championzone.net 17102

Suzan Fine Executive Assistant Jossef Goldberg Office of the President 555-0101 susan@championzone.net Assistant 17104

Clair Hector COO Jossef Goldberg Operations 555-0102 clair@championzone.net 17106

**Character Delimited**

Name#Title#Manager#Department#Telephone#E-mail#Master_Shape#Office Number

Jossef Goldberg#President & CEO#Office of the President#555-0100#jossef@championzone.net#17102

Suzan Fine#Executive Assistant#Jossef Goldberg#Office of the President#555-0101#susan@championzone.net#Assistant#17104

Clair Hector#COO#Jossef Goldberg#Operations#555-0102#clair@championzone.net#17106

A Microsoft Office Excel Workbook file
A Microsoft Office Excel Workbook (spreadsheet) may be utilized as a valid data source. The only caveat is that Row “1”, the first row, MUST be the headers of the columns of information presented below.

The header titles are listed in row 1. The Header Titles can be anything the creator desires. They will be mapped in the Wizard to the “Who am I”, and the “Who do I report to” fields.

The data in Column A “Employee”, must be in exactly the same format as the data in Column C “Reports_To” in order for the Wizard to understand the hierarchal relationship. In other words, if the name in the Employee column is “Jossef Goldberg”, then the name in the Reports_To column must also be “Jossef Goldberg”, not “Joe Goldberg”, or “Joseph Goldberg”. An exact match is necessary for the structuring algorithm to work properly.

An Org Plus file (saved in .TXT format)

An OrgPlus file may be used as a valid data input source. However, the OrgPlus file must be already saved in OrgPlus’ text format file structure PRIOR to attempting the import of the data into Visio.

An ODBC-Compliant Data Source

Additionally, ANY ODBC-compliant data source may be used as a data input source for the Organization Chart Wizard. The only caveat is that the ODBC-compliant data source must also contain in the same table or view or query, the two data fields for “Who am I”, and “Who do I report to”.

This means that a Microsoft Office Access database, a Microsoft SQL database, a PeopleSoft database, an Oracle database, or any other data base (ODBC-compliant) is valid as an input source.

Left-Click the Next > Command Button to advance to the Third Screen of the Organization Chart Wizard.

The third screen solicits the user to both enter the complete path, and file name, for the input source file, or Left-Click on the Browse… Command Button to display a Windows File Selection dialog.

If the Browse… function is utilized, the creator will need to Left-Click on the Open Command Button to confirm the selection of the file and return the complete path and filename to the Organization Chart Wizard.

NOTE: After the first usage of the Wizard, the Wizard remembers this file and path as well as all other settings in the Wizard. This is because in Visio, Organization Chart Diagrams are referred to as “disposable” diagrams. This DOES NOT mean that they are any less important than any other diagram type. It is simply that it is so quick and easy to generate an Organizational Chart Diagram, that if the data changes, a new diagram can be generated on the fly. Therefore, if the creator has already answered the questions in the Wizard the first time through, why should he or she be required to answer them again? Visio remembers all the previous run’s settings, and therefore the next time the creator wishes to generate a new Organization Chart Diagram from the same data source, he or she simply needs to repetitively click the Next Command Button (and finally the Finish Command Button) to rapidly generate the diagram. The creator simply Left-Clicks “Next”, “Next”, “Next”, “Next”, “Next”, “Next”, and “Finish”.

**Locating the data file**

As stated before, the creator has full control to Browse for the data source file by Left-Clicking on the Browse… Command Button. The source file may be either on the creator’s own local PC or on any PC or Server attached to the network that the creator can access.
Specifying the language

Though rarely necessary to alter, the creator can specify an alternate language set for the data source to be input. Therefore Simplified Chinese, Kanji, Cyrillic, etc. may be specified as necessary.

Left-Click the Next > Command Button to advance to the Fourth Screen of the Organization Chart Wizard.

The Fourth screen is where the mapping between the source data fields, and the fields that the Wizard needs, takes place.

Data Fields

There are two mandatory and one optional data fields; Name, and Reports to, as well as First name (optional).

Name

The Name field equates to the Employee Name within the organization. Select the data field from the data source that references the Employee Name.

Reports to

The Reports to field equates to the Manager or Supervisor Name within the organization. Select the data field from the data source that references the Manager or Supervisor Name.

First name (optional)

The optional First name field may be used in conjunction with the Name field if, in the data source, these two items are in separate fields. If, in the data source, the First Name field contains the value “Jossef” and the Last Name field contains the value “Goldberg”. Then in the Wizard the Name field would be mapped to “Last Name” and the optional First Name field would be mapped to “First Name”. The Reports to field in the Wizard would map to the “Manager field in the data source.

Left-Click the Next > Command Button to advance to the Fifth Screen of the Organization Chart Wizard.

The fifth screen in the Wizard is where the fields of data to be displayed on the face of the SmartShape symbol will be configured.

Displayed Fields

The data file columns listing contains all of the data field columns as discovered by the Wizard from the data source. The Displayed fields listing contains the list of fields to be displayed, and in which order, on the face of the SmartShape symbol.

By utilizing the Add > and the Remove < Command Buttons, items from the Left and Right columns can be transferred back and forth.

By utilizing the Up and Down Command Buttons, items in the Right Column, those to be displayed on the face of the SmartShape symbol, can be re-ordered to suit the requirements of the creator of the new Organizational Chart.

Adding

To add a data item to the display on the face of the SmartShape, Left-Click the item in the Left Column, then Left-Click the Add > Command Button.
Removing
To remove a data item from the display on the face of the SmartShape, Left-Click the item in the Right Column, then Left-Click the < Remove Command Button.

Reordering
To display any item in the Displayed fields listing higher in “Top-to-Bottom” order, Left-Click the desired item in the Right Column and then Left-Click the Up Command Button. To display any item in the Displayed fields listing lower in “Top-to-Bottom” order, Left-Click the desired item in the Right Column and then Left-Click the Down Command Button.

Left-Click the Next > Command Button to advance to the Sixth Screen of the Organization Chart Wizard.

The Sixth screen of the Organization Chart Wizard contains options to include or exclude data fields from the data source as Shape Data attached to the SmartShape symbol.

*Shape Data Fields*

The data file columns listing contains all of the data field columns as discovered by the Wizard from the data source. The Shape Data fields listing contains the list of fields to be attached to the SmartShape symbol as Shape Data items.

By utilizing the Add > and the Remove < Command Buttons, items from the Left and Right columns can be transferred back and forth.

Adding
To add a data item to the Shape Data items attached to the SmartShape, Left-Click the item in the Left Column, then Left-Click the Add > Command Button.

Removing
To remove a data item from the Shape Data items attached to the SmartShape, Left-Click the item in the Right Column, then Left-Click the < Remove Command Button.

Left-Click the Next > Command Button to advance to the Seventh and Final Screen of the Organization Chart Wizard.

The Seventh and Final screen of the Organization Chart Wizard contains options controlling the breakdown of the Hierarchy of the diagram as well as options for hyperlinking and synchronization.

*Breaking Down the Organization by Hierarchy*

The creator of the Organizational Chart can opt to either allow the Visio Organization Chart Wizard make its own decisions as to how the Organizational Structure should be broken down, or, alternately, exercise manual control over the breakdown structure.

User Specified Breakdown
To manually specify the breakdown points for breaking out teams to their own individual pages, ensure that the “I want to specify how much of my organization to display on each page” radio button is selected.
Wizard Calculated Breakdown

To allow the Visio Organization Chart Wizard to specify the breakdown points for breaking out teams to their own individual pages, ensure that the “I want the wizard to automatically break my organization chart across pages” radio button is selected.

Utilizing the optional Name at top of Page drop-down listing the creator can either let the Wizard place the name of the top-level data entry as the highest ranking person and build the hierarchy from there (this is the default), or opt to manually select the highest ranking person to begin the hierarchy on the first page of the completed Organization Chart Diagram.

Hyperlinks

The “Hyperlink employee shapes across pages” check box allows the creator to determine if the Wizard should automatically establish hyperlinks between superiors on one page and their expanded teams on subsequent pages, by checking, or un-checking the Check Box.

Synchronization

The “Synchronize employee shapes across pages” check box allows the creator to determine if the Wizard should automatically maintain the synchronization between pages for rolled up teams on one page and their expanded teams on subsequent pages, by checking, or un-checking the Check Box.

Left-Click the Finish Command Button to confirm all of the choices made in the Organization Chart Wizard, close the Wizard, and complete the building of the entire Organization Chart Diagram.

When complete, the wizard will close, then display two progress dialogs as it proceeds to generate the organizational hierarchy. Upon successful completion of all of the Wizard’s tasks, the creator/user will be confronted with the final page of the diagram.

At any time thereafter, the user can utilize the Page Tabs and Page VCR-style controls to navigate back to the first page (“management roll-up”) of the Visio Organization Chart Diagram.

TRICKS FOR GLOBAL APPLICATION OF BACKGROUNDS TO ORGANIZATIONAL CHARTS

One of the frustrations that users of Visio Organizational Chart Diagrams experience is that once they have learned about the power of Background Pages, they create a Background Page and then struggle through applying that background to each of the many foreground pages in the diagram. The key to overcoming the frustration and intensive labor of setting page properties numerous times is to create the Background Page PRIOR to running the Visio Organization Chart Wizard.

Here are the steps:

1. Begin a new Visio Organizational Chart Diagram based on the Visio Organization Chart Wizard Template or the Visio Organization Chart Template.
2. If the Visio Organization Chart Wizard launches, CANCEL the Wizard by Left-Clicking on the Cancel Command Button on the First Screen of the Wizard.
3. Create a Background Page. Choose Insert – New Page from the Visio Insert Menu. In the Page Setup Dialog, on the Page Properties Tab Left-Click on the Background Radio Button for the Type Field. If desired, provide a preferred name for the background page, or accept the default name of “Background-1”. Left-Click the OK Command Button to confirm the choices and close the dialog.
4. Add all required elements to the Background Page.
5. Return to the First Page (Page-1) of the Diagram.
7. In the Page Setup Dialog, on the Page Properties Tab, in the Background drop-down listing, choose the newly created Background page (Background-1) as the assigned background page for this foreground page. Left-Click the OK Command Button to confirm the choices and close the dialog.
8. Restart the Organization Chart Wizard by choosing Organization Chart ➤ Import Organization Data… from the Visio Organization Chart Menu.
9. Continue through all Screens of the Wizard.

As the Wizard builds the pages of the Diagram, Visio will automatically assign the designated Background page to each of the new Foreground pages.

If a Visio Organization Chart Diagram has already been created, and that diagram does not already contain a Background, the creator can quickly add a Background to a page by dragging a background from the Visio Backgrounds Stencil.

Upon dropping the desired background, Visio will create the Background Page and assign it to the current Foreground Page.

To then apply the Background page to every subsequent Foreground page, choose File Page Setup… from the Visio File Menu.

In the Page Setup Dialog, on the Page Properties Tab, in the Background drop-down listing, choose the newly created Background page (Background-1) as the assigned background page for this foreground page. Left-Click the OK Command Button to confirm the choices and close the dialog.

This process of assigning a Background page to each and every Foreground page will need to be accomplished once for each Foreground Page. Ensure that the desired Foreground Page is active prior to going through the process of assigning the Background page.

Remember that once a Background page has been created, additional “static” elements such as Title Blocks, Borders, and Corporate Logos may be added to the Background Page and those elements will be visible to each and every Foreground page with that Background page assigned to it.

**EDITING CONTENT ON THE FACE OF ORGANIZATIONAL DIAGRAM SmartShape symbols**

To access the options under Visio 2007 choose Organization Chart ➤ Options… from the Visio Organization Chart menu. Under Visio 2010, on the Org Chart Ribbon, in the Organization Area, select the Display Options Item.

This action will display the Options dialog with the Options dialog open to the Options tab as its focus.

The Fields Tab of the Options Dialog includes the following options: Block 1 Field Display Choices, Blocks 2 through 5 Field Choice, and the Restore Defaults option.

**Block 1**

The Block 1 area controls the display field(s) for the main text block for the Organizational Charting SmartShape symbols. The user can configure the display of the Name, Title, Department, E-mail, and Telephone fields. Each item checked will display in the center text block, each unchecked item will not display.
**Block(s) 2 through 5**

For each of the Block 2, Block 3, Block 4, and Block 5, a drop-down list of fields to be displayed in the respective area as shown on the diagram within the dialog is available. For each additional field that is desired to be displayed in each of the blocks, choose the desired field.

**Restoring Defaults**

The Restore Defaults Command Button, when Left-Clicked, will reset the field information back to the default state, showing only the Name and Title as entered in the Shape Data fields of the SmartShape symbol.

**Text**

The Text Tab of the Options dialog contains options to set the Font, Font Size, and Font Color as well as the bolding and italicization for the displayed fields.

**Fields**

The Fields provides a listing of the currently displayed fields associated with the SmartShape symbol. In order to change any of the characteristics of the text of any of the fields, the particular field must be selected. For example, to change the Font and point size and color of the text displaying the employee’s name, the Name field would need to be selected in this drop-down listing. This process would need to be repeated for each desired field.

**Font**

Using the Font drop-down list, the user may select and apply the given Font Type to be associated with the selected field.

**Size**

Using the Size drop-down list, the user may select and apply the given Font Size (in Points) to be associated with the selected field.

**Color**

Using the Color drop-down list, the user may select and apply the given Font Color (among the first 24 indexed colors) to be associated with the selected field.

**Style Bold**

Using the Bold Check Box, the user may select and apply whether the given Font to be associated with the selected field is or is not bolded.

**Style Italic**

Using the Italic Check Box, the user may select and apply whether the given Font to be associated with the selected field is or is not italicized.

When all Options have been set in the Options Dialog, Left-Click on the OK Command Button to confirm the desired Option Configuration settings, close the dialog, and apply the changes.
EDITING THE SIZE OF ORGANIZATIONAL DIAGRAM SmartShape Symbols

To access the options choose Organization Chart  Options… from the Visio Organization Chart menu. This action will display the Options dialog with the Options dialog open to the Options tab as its focus.

Options

The available Options on the Options tab are the Width and Height of the SmartShape symbol, whether or not to show pictures on the face of the SmartShape symbol, Whether or not to show the divider line between the Name and Title fields on the face of the SmartShape symbol, whether or not to show drawing tips when available, and whether or not to use these option settings for new organization charts.

Shape Display Width

The Shape Display Width has both a scroll arrow set and a direct text entry. Modifying the value in this field changes the width of all of the Organizational Charting SmartShape symbols in the current diagram.

Shape Display Height

The Shape Display Height has both a scroll arrow set and a direct text entry. Modifying the value in this field changes the height of all of the Organizational Charting SmartShape symbols in the current diagram.

When all Options have been set in the Options Dialog, Left-Click on the OK Command Button to confirm the desired Option Configuration settings, close the dialog, and apply the changes.

ADDING PHOTOGRAPHS TO ORGANIZATIONAL DIAGRAM SmartShape symbols

All of the Organizational SmartShape symbols that represent members of the Organization (with the exception of the Staff SmartShape symbol) are capable of having a Picture associated with them. Pictures may be imported from any available source accessible from the user’s network and may be in *.emz, *.emf, *.gif, *.jpg, *.png, *.svg, *.svgz, *.tiff, *.bmp, *.dib, or *.wmf format.

To add a picture to an Organizational SmartShape symbol, Right-Click on the selected SmartShape symbol and select Insert Picture… from the SmartShape symbol’s context menu.

This action will cause a file dialog to display. Browse to the network or PC Drive, Directory, and File where the required picture resides. Select the Picture file. When selected, Left-Click the Open Command Button to confirm the choice and close the dialog. The Picture will automatically be resized and will be added to the SmartShape symbol.

OTHER NOTABLE CORE (STANDARD EDITION) DIAGRAM TYPES

The Available Microsoft Office Visio 2007 / 2010 Standard Edition Diagram Types / Solutions include:

- Audit Diagram
- Basic Diagram
- Basic Flowchart Diagram
- Basic Network Diagram
- Block Diagram
- Block Diagram with Perspective
- Brainstorming Diagram (covered in this Guide)
- Calendar Diagram
- GANTT Chart Diagram
- Cause and Effect Diagram
- Charts and Graphs Diagrams
VISIO ADVANCED FUNCTIONALITY & FEATURES

TEXT FIELDS

Text Fields in the Visio environment are very similar to Text Fields as experienced in Microsoft Office Word; that is, Text Fields are automatically updated data fields which display many diverse forms of information about the Visio Diagram, the Visio Page, or Shape Data information associated with an individual SmartShape symbol.

To add a Text Field to a SmartShape symbol, you must first be in Text Editing mode. To enter Text Editing Mode for an individual SmartShape symbol, either Double-Click (using the Left Mouse Button) on the face of the SmartShape symbol, or select the Text Tool (the large black capital letter “A” on the Visio Standard Toolbar). At this point you should see a blinking vertical cursor indicator on the SmartShape symbol.

Next, choose Insert Field... from the Visio Insert menu. This action will cause the Field Dialog to be displayed.

The Left Column in the Field dialog contains a listing of the available categories of information that may be added to the text on the face of the SmartShape symbol. These categories include: (1) Shape Data, (2) Date / Time, (3) Document Info, (4) Page Info, (5) Geometry, (6) Object Info, (7) User-defined Cells, and (8) Custom Formula.

For this example, use a Process SmartShape symbol from the Basic Flowchart Shapes Stencil. Ensure that the Cost, Duration, and Resources Shape Data fields have valid values entered.

Choose the Category “Shape Data” from the Left Column, Category, by Left-Clicking on the “Shape Data” item. This action will display the three defined Shape Data fields in the Right Column. These three Shape Data items are: (1) Cost, (2) Duration, and (3) Resources.

Choose the Cost Shape Data item by Left-Clicking on the Cost item in the Right Column.

With this choice made, Left-Click on the OK Command Button to confirm your choice, close the dialog, and apply the Text Field to the Text of the SmartShape symbol.

Notice that the current value assigned to the Cost Shape Data field of the SmartShape symbol is now displayed as Text on the face of the SmartShape symbol. Any change to the value of the Shape Data field will result in that updated value being presented as Text on the face of the SmartShape symbol.
CUSTOM REPORTS

Every Visio diagram contains at least one Report Definition, an Inventory Report. Based upon the Template that the Diagram was based upon, the diagram may contain additional Custom Report Definitions.

Accessing all of the available Report Definitions is accomplished in exactly the same manner.

Under Visio 2007, Choose Data ➤ Reports… from the Visio Data menu.

Under Visio 2010, go to the Review Tab, go to the Reports area, and select the Shape Reports item.

This action will first display a progress bar while Visio locates and loads the applicable Report Definitions. Visio will then display the Reports dialog.

Note that the Inventory report, and any other available report listings are all displayed in the Reports dialog.

CUSTOM DESIGNED CUSTOM REPORTS

If none of the included Report Definitions suit the needs of your organization, then Custom Report Definitions may be created as well. These Custom Report Definitions may be either stored in the Visio Diagram, or stored to any Network share, such that any other Visio user of the Organization Chart Solution would have access to the Report Definition as well.

To create a Custom Report Definition, begin by launching the Visio Report Tool. As stated before, this is accomplished by choosing Data ➤ Reports… from the Visio Data menu.

Next, from within the Report Dialog, Left-Click on the New… Command Button. This action will display the first screen of the Report Definition Wizard

Note that you can specify the scope of the Report to be either (a) all shapes on all of the pages in the current diagram, (b) all of the shapes on the current page, (c) shapes that are selected, or (d) a specific class of shapes such as Organization Chart SmartShape symbols.

Note also, the Advanced… Command Button. Left-Click on the Advanced… Command Button. This action will display the Advanced sub-Wizard Screen

The Advanced Screen allows the filtering of the SmartShape symbols to be included in the report. This eliminates all dynamic connectors and other superfluous SmartShape symbols from being included in the Report. After the Property, the Condition, and the Value fields are selected from their respective drop-down lists, Left-Click the Add Command Button to add the given condition. When all proper conditions are set, Left-Click the OK Command Button to return to the first screen of the Report Definition Wizard.

Left-Click the Next> Command Button to advance to the next screen of the Wizard.

The second screen of the wizard allows you to specify which fields (Shape Data fields) should be included in the Report Definition. Check the specific fields to add to the report definition.

Left-Click the Next> Command Button to advance to the next screen of the Wizard.

The third screen of the wizard allows you to specify the Report Title, the Grouping, the Sorting, and the formatting of the report elements.

Left-Click the Next> Command Button to advance to the next screen of the Wizard.
The fourth (and final) screen of the wizard allows you to specify the name for the report definition, and the location.

Left-Click the Finish Command Button to accept the choices, close the Wizard, and return to the Report Dialog.

**RUNNING CUSTOM REPORTS AND OUTPUT TARGETS**

To run a Report, select the desired Report Definition by Left-Clicking on the desired Report Definition in the listing and then Left-Click on the Run... Command Button.

This action will display the Run Report dialog.

Note that there are Four possible Report Output formats available: (1) Excel (Microsoft Office Excel Workbook), (2) HTML (.HTML File Output in a Table format), (3) Visio Shape (actually an embedded Excel worksheet), and (4) XML (a raw .XML ASCI Text format document).

Left-Click on any of the desired four output formats, in this case you may use Excel as the output. Finally, Left-Click on the OK Command Button to generate the Report.

**DATABASE CONNECTIVITY**

**THE DATABASE WIZARD [ Visio 2007 AND PRIOR ]**

The Visio Database Wizard has been available in Visio for numerous releases, and is still a viable Data connectivity tool under Visio 2007. The difference between the older Visio Database Wizard and the new Visio 2007 Database Connectivity Wizard are the following:

The Database Wizard allows for bi-directional communication between the Visio SmartShape symbol and the record in the Database table, whereas the new Database Connectivity Wizard is a “Read Only”, or “Pull” technology from the Database Record.

The Database Wizard is capable of attaching to only one table or view in one data source, whereas the new Database Connectivity Wizard can attach to multiple data sources at the same time.

Prior to starting the Database Wizard, ensure that you have a valid SmartShape symbol on the Visio Diagram Page, and that the SmartShape symbol is selected by Left-Clicking on the SmartShape symbol.

To begin the Visio Database Wizard, choose Tools ➤ Add-Ons ➤ Visio Extras ➤ Database Wizard from the Visio Tools Menu. This action will display the first screen of the Database Wizard.

The First Screen of the Wizard is an overview of its capabilities displayed as a “For Your Information” type of screen. Left-Click on the Next > Command Button to advance to the Second Screen of the Wizard.

The Second Screen of the Wizard asks you to choose the action you are trying to accomplish. Choose the option that states “Link shapes to database records”. Left-Click on the Next > Command Button to advance to the Third Screen of the Wizard.

The Third Screen of the Wizard asks you to choose the shape type for which you want to define links. Choose the option that states “Shape(s) in a drawing”. Left-Click on the Next > Command Button to advance to the Fourth Screen of the Wizard.

The Fourth Screen of the Wizard asks you to select the Drawing, the Page, and the Shape to link to the Database Record. Note that the current Drawing, and the current Page are already filled in. Note that
the SmartShape symbol that you pre-selected is also already chosen. Left-Click on the Next > Command Button to advance to the Fifth Screen of the Wizard.

The Fifth Screen of the Wizard asks you to choose the Data Source to connect to, from the list of Data Sources your PC knows about. Either select the data source, or, if the appropriate data source is not listed, Left-Click on either the “Browse for File DSN...” Command Button, or the “Create Data Source...” Command Button to find or create a data source to connect to. In the case of this example we will connect to the Visio Database Samples Data Source. Left-Click on the “Visio Database Samples” data source to select it. Left-Click on the Next > Command Button to advance to the Sixth Screen of the Wizard.

The Sixth Screen of the Wizard asks you to choose the specific Table or View (Query) to connect to. Scroll down through the listing of available Tables and Views until you locate the “Office – Employee Details” Table. Left-Click to choose the “Office – Employee Details” Table. Left-Click on the Next > Command Button to advance to the Seventh Screen of the Wizard.

The Seventh Screen of the Wizard asks you to choose the number of fields that comprise the primary key. Since this Table has a Primary Key field “Name” (as in Employee’s Name) and it is a single field, leave the Number of Key Fields set to the number 1. Left-Click on the Next > Command Button to advance to the Eighth Screen of the Wizard.

The Eighth Screen of the Wizard asks you to choose the Key Field’s Name. In this case the field “Name” (as in Employee’s Name) is the key Field. Left-Click to choose this field. Left-Click on the Next > Command Button to advance to the Ninth Screen of the Wizard.

The Ninth Screen of the Wizard asks you to choose a default record to assign to the SmartShape symbol. If, as a SmartShape symbol were instanced in the Diagram, the desire was to have a default value instantiated, then you would select the desired record from the listing. In the case of this example, you want Visio to prompt you to select a record on drop, so you should Left-Click on the None Command Button to ensure that No Default Record is assigned. This action will advance you to the Tenth Screen of the Wizard.

The Tenth Screen of the Wizard asks you to choose an action to be assigned to the On-Drop event for the SmartShape symbol. Choose the option (Check Box) that states “Include an on drop event with the shape.” And the option (radio button) that states “Select record on drop”. This screen also provides up to four Context Menu Items (Right-Click Menu Choices) that may be added to the SmartShape symbol. The first option adds a context menu item to Select a Database Record. This means at any time you can choose to point to a different record if you wish. Ensure that this option is checked. The second option adds a context menu item to Refresh Shape Cells. This means that if data in the data source changes you can update the SmartShape symbol with the changed data. Ensure that this option is checked. The third option adds a context menu item to Update Database Record. This means that if data in the Shape Data fields in the SmartShape symbol change, these changes can be pushed back to the data source and update the data source. This may, or may not, be desired. Therefore Check or Un-Check this option at your discretion. The fourth option adds a context menu item to Delete Shape and Database Record. This means that when the SmartShape symbol is deleted from the Diagram, the corresponding database record will be deleted from the data source. This option is rarely used. Therefore Check or Un-Check this option at your discretion. When your choices have been made in this screen, Left-Click on the Next > Command Button to advance to the Eleventh Screen of the Wizard.

The Eleventh Screen of the Wizard asks you to choose the shape cell to be used for storing the primary key field value. The default will be Prop.(same name as key field in the data source). In this case, since the primary key was Name, as in Employee’s Name, the suggested field in the SmartShape symbol is
“Prop.Name”. This is absolutely acceptable. Left-Click to choose this field name. Left-Click on the Next > Command Button to advance to the Twelfth Screen of the Wizard.

The Twelfth Screen of the Wizard asks you to map the remaining fields from the data source to either existing or suggested Shape Data fields in the SmartShape symbol. Left-Click on the “Department” field in the Database Fields: Column, then scroll down and Left-Click to choose the “Prop.Department” field from the Cells: Column. Left-Click on the Add > Command Button to add the mapping in the Links Column. Repeat this process for the “Extension” and “Prop.Extension”, and the “Title” and “Prop.Title” items. Left-Click on the Next > Command Button to advance to the Thirteenth Screen of the Wizard.

The Thirteenth (and Final) Screen of the Wizard provides a summary of the actions you have requested. If these are all correct, Left-Click the Finish Command Button to accept your choices, close the Wizard and update the SmartShape symbol with the appropriate data source links and custom Context Menu Action Items.

Each time this data connected SmartShape symbol is instanced, a dialog will appear requesting you to select a record. As discussed above, the Context Menu Actions are available with a Right-Click action on the SmartShape symbol. The linked data is being stored in the SmartShape symbol’s Shape Data fields, and can be made visible on the face of the SmartShape utilizing Text Fields as discussed above.

**THE NEW VISIO 2007 / 2010 DATABASE CONNECTIVITY WIZARD**

The first task is to link a data source to the Visio diagram as a whole. Later the links will be established between the individual records and the unique SmartShape symbols.

Begin under Visio 2007 by choosing Data ▶ Link Data to Shapes... from the Visio Data menu

Begin under Visio 2010 by going to the Data Tab of the Ribbon, and from the External Data area, select the Link Data to Shapes item.

This action will display the Data Selector dialog.

The first question that requires a selection is “What data do you want to use?”. The potential choices are (1) a Microsoft Office Excel workbook, (2) a Microsoft Office Access database, (3) a Microsoft Windows SharePoint Services list, (4) a Microsoft SQL Server database, and (5) any Other OLEDB or ODBC data source. In the case of this example, the Excel workbook will be selected. Left-Clicking on the Next> Command Button advances to the next screen of the Data Selector Wizard.

The next step is to browse to the desired data source. Left-Clicking the Browse... Command Button displays a File Dialog allowing you to select the desired file from the network file system.

When complete, the required file name will be displayed in the Text Box. Left-Clicking on the Next> Command Button advances to the next screen of the Data Selector Wizard.

Because an Excel workbook was selected, the Wizard offers you the opportunity to select a specific range of data on the worksheet. If no named range is available, you can create one on the fly or simply use the entire worksheet. Left-Clicking on the Next> Command Button advances to the next screen of the Data Selector Wizard.

Utilizing the Select Columns... and Select Rows... Command Buttons, you can filter the selection of data being used for the data link.

Select Columns... allows individual fields to be included or excluded from the data link.

Select Rows... allows individual records to be included or excluded from the data link.
Once any filters have been applied to the data set, you are returned to the Connect to Data screen of the Wizard. Left-Clicking on the Next> Command Button advances to the next screen of the Data Selector Wizard.

The Wizard takes a first pass estimate at which field in the data set contains unique record entries and offers this as the Unique Identifier. You may either accept this default, or un-check that option and select another. Left-Clicking on the Next> Command Button advances to the next screen of the Data Selector Wizard.

The final screen of the Wizard simply confirms that the Wizard has all of the necessary information to import the data to the Visio Diagram as a whole. Left-Clicking the Finish Command Button confirms your choices, closes the dialog and attached the data set to the Visio diagram.

The above process would be repeated to attach the second data or any subsequent data source.

**THE NEW VISIO 2007 / 2010 AUTOMATICALLY LINK WIZARD**

With the Data Source attached, the next step is to automatically link the records in the imported data source to individual SmartShape symbols. To begin this process under Visio 2007, choose Data ▸ Automatically Link… from the Visio Data menu. Begin under Visio 2010 by going to the Data Tab of the Ribbon, and from the External Data area, select the Automatically Link item.

This action will display the Automatic Link dialog.

The first screen of the dialog requests the scope of the linking. You can opt to either automatically link to any specifically selected shapes, or, All shapes on the current page. Ensure that the “All shapes on this page” option is selected Left-Clicking on the Next> Command Button advances to the next screen of the Automatic Link Wizard.

In this screen of the Automatic Link Wizard you map the field in the data source to the field in the SmartShape symbol’s Shape Data. There is an AND Command Button allowing for multiple criteria, however there is no OR functionality. In the case of this example, ensure that the unique key field is selected in BOTH the Data Column and the Shape Field lists. Left-Clicking on the Next> Command Button advances to the next screen of the Automatic Link Wizard.

The final screen of the Wizard restates the actions that have been selected and will be executed. Left-Clicking on the Finish Command Button closes the Automatic Link Wizard, and scans the diagram for matching criteria. Wherever the criteria match, Visio places a small chain-link symbol at the left of the record in the data set in the diagram and performs the link.

This would be repeated for each and every page in the diagram, for each attached data set.

**THE NEW VISIO 2007 / 2010 DATA CONNECTIVITY DATA REFRESH WIZARD**

When data changes in the data set(s), the Visio diagram can be updated to reflect these changes. To perform a refresh under Visio 2007, either choose Data ▸ Refresh Data... from the Visio Data menu, or Right-Click on the attached data grid at the bottom of the Visio Environment and choose Data ▸ Refresh Data... from the context menu of the data grid. Both methods will display the Refresh Data dialog. To perform a refresh under Visio 2010, begin by going to the Data Tab of the Ribbon, and from the External Data area, select the Refresh All item (for further options, select the drop-down under the Refresh All item).

From within the Refresh Data dialog, either Left-Click the Refresh Command Button to refresh the data from the currently selected data source, or Left-Click the Refresh All Command Button to refresh the
data from all listed data sources. Left-Clicking the Configure... Command Button displays a sub-dialog which provides options to schedule refreshes on a given interval.

**DATA GRAPHICS**

While an amazing amount of intelligence can, and is, programmed directly into Visio SmartShape symbols, many solutions are required to maintain the SmartShape symbols in a rigid manner in order for the solution to perform in the desired way. Visio has created a new technology under Visio 2007 Professional called Data Graphics.

Data Graphics are designed to associate additional sub-SmartShape symbols to existing SmartShape symbols. These Data Graphics are often used to display Key Performance Indicators (KPI's) associated with the SmartShape symbols within the diagram.

There are four distinct types of Data Graphics. A Data Graphic set can include any number of Data Graphics at the same time. Any number of Data Graphic Sets can be saved as part of a Visio diagram, and any of these Data Graphic sets can be applied at any time the user desires. In this manner a single Visio diagram can display numerous KPI visualizations.

The four distinct Data Graphic Items are:

- Text Callouts
- Data Bars
- Icon Sets
- Color by Value

**CREATING DATA GRAPHICS SETS**

Data Graphics are created through the Data Graphics Task Pane under Visio 2007, and within the Data Graphics Mini-Window under Visio 2010. The Data Graphics Task Pane is accessed under Visio 2007 Professional by choosing Data → Display Data on Shapes... from the Visio Data menu. Under Visio 2010 Professional and Premium go to the Data Tab of the Ribbon, and in the Display Data area, in the Data Graphics drop-down, select Create New Data Graphic...

This action, under Visio 2007, opens the Data Graphics Task Pane at the Right of the Visio Environment. Under Visio 2010, it displays the Data Graphics Mini-Window. To create a new Data Graphic Set, Left-Click on the New Data Graphic... text item near the top of the Task Pane.

This action displays the New Data Graphic dialog. The New Item Command Button/List reveals the four potential Data Graphic Items which may be included in a Data Graphic Set.

**Text Callouts**

Left-Clicking the Text ... option displays the New Text sub-dialog.

In this sub-dialog you can choose from a list of available text callout styles, and select other options including the position of the callout, the label, the border type, etc. You MUST choose the Data field that is to be associated with the callout.

**Data Bars**

Left-Clicking the Data Bar ... option displays the New Data Bar sub-dialog.
In this sub-dialog you can choose from a list of available Data Bar styles, and select other options including the position of the Data Bar, the label, the minimum and maximum values, etc. You MUST choose the Data field that is to be associated with the Data Bar.

**Icon Sets**

Left-Clicking the Icon Set … option displays the New Icon Set sub-dialog.

In this sub-dialog you can choose from a list of available Icon Set styles, and select other options including the position of the Icon, the label, the logic and values, etc. You MUST choose the Data field that is to be associated with the Icon Set. Note that you may also create your own Icon Set to meet your particular corporate needs. Please refer to Microsoft Knowledgebase articles on how to create and use new Visio 2007 Professional, and Visio 2010 Professional and Premium Icon Sets.

**Color by Value**

Left-Clicking the Color by Value … option displays the New Color by Value sub-dialog.

In this sub-dialog you can choose from a list of available colors to assign to each possible value (note that these colors apply to either or both fill color and text color), and select other options as well. You MUST choose the Data field that is to be associated with the Color by Value.

**APPLYING DATA GRAPHICS SETS**

To apply a Data Graphic Set to a Visio Diagram, first select the SmartShape symbols that are to have the Data Graphic Set applied to them, then Left-Click on the Data Graphic set in question.

**NEW VISIO 2007 and 2010 PIVOT DIAGRAMS**

An entirely new type of diagram has been introduced with Microsoft Office Visio 2007 Professional Edition and continued in Visio 2010 in both Professional and Premium Editions. This new Diagram type is called a Pivot Diagram. Similar to Microsoft Office Excel Pivot Tables, Visio Pivot Diagrams provide unique visualizations of the data in hierarchal manner based on your preference. Unlike Excel Pivot Tables, however, Visio Pivot Diagrams require almost no set up and are amazingly easy to create and use.

To begin a new Visio Pivot Diagram under Visio 2007 choose File ➤ New ➤ Business ➤ Pivot Diagram from the Visio File Menu. Under Visio 2010 Go to the Backstage area, in the Business Templates area, choose a Pivot Diagram, select the units and left-click the Create item. This action will begin a new Pivot Diagram and display the First Screen of the Data Selector Wizard.

**ATTACHING A DATA SOURCE**

Before Data can be visualized in a Pivot Diagram, the diagram must be attached to the data. As the Pivot Diagram is created you are confronted with the First Screen of the Data Selector Wizard. This Screen asks you to choose the data source type you wish to attach to. This data source type can be: (1) Microsoft Office Excel workbook, (2) Microsoft Office Access database, (3) Microsoft Windows SharePoint Services list, (4) Microsoft SQL Server database, (5) Microsoft SQL Server Analysis Services, or (6) Other OLEDB or ODBC data source. Left-Click on the desired Radio Button to choose the desired data source from the list. In the case of this example, choose Microsoft Office Excel workbook. Left-Click the Next > Command Button to advance to the Second Screen of the Data Selector Wizard.

The Second Screen of the Data Selector Wizard asks you to either enter the full path and file name of the desired Excel workbook, or Left-Click on the Browse... Command Button to open a Windows File Dialog.
to select the desired Excel Workbook. In the case of this example browse to an Excel Workbook containing Organizational Information as was used in the Organization Chart example. When you have selected the proper data source, Left-Click the Open Command Button in the File Dialog to return to the Second Screen of the Data Selector Wizard. Left-Click the Next > Command Button to advance to the Third Screen of the Data Selector Wizard.

The Third Screen of the Data Selector Wizard asks you to select a custom defined range for the Worksheet or, by default, the entire worksheet. For this example, simply leave the default selected. Left-Click the Next > Command Button to advance to the Fourth Screen of the Data Selector Wizard.

The Fourth Screen of the Data Selector Wizard asks you to select either the Columns of Data to include or exclude, or the Rows of Data to include or exclude. In the case of this example, you will include all data, therefore leave the defaults for (All Columns) and (All Data) selected. Left-Click the Next > Command Button to advance to the Fifth Screen of the Data Selector Wizard.

The Fifth (and final) Screen of the Data Selector Wizard simply informs you that you have successfully imported your data. Left-Click on the Finish Command Button to accept your choices, close the Wizard, and generate the Top Node of your Pivot Diagram.

When the Wizard Completes, the Wizard adds three items (by default) in the Upper-Left-Hand-Corner of your diagram: (1) A Top Level Node (represented by a White Box with a Blur Header item at the top), (2) A Title SmartShape symbol representing the name of the data source being visualized, and (3) a legend of information about the data connectivity.

**EXPANDING NODES**

The Top Level Node is the starting point for the Visualization. Perhaps you want to “drill in” on the overall Organization to see what departments exist in the Organization. To accomplish this, you can either (1) Right-Click on the Top Level Node and Select “Department” from the Context Menu list of available fields, or (2) look to the Left of the Diagramming area in the Add Category area of the Pivot Diagram Task pane, and select “Department” from the list of Categories. Either method will expand the Pivot Diagram and “Drill Down”, showing you all of the Departments within the Organization. Notice that Visio will take care of any and all page resizing.

**COLLAPSING NODES**

To Collapse all of the Children Nodes under the Parent Node, simply Right-Click on the Parent Node and choose Collapse from the Context Menu.

**CHANGING DIRECTION OF A NODE TIER**

By default, nodes are laid out in a horizontal manner under the Parent Node. The Direction of the Layout can be altered from Horizontal to Vertical and Back by first selecting the Parent Node, then selecting any one of the four options PivotDiagram ▶️ Layout Direction ▶️ Top-to-Bottom, PivotDiagram ▶️ Layout Direction ▶️ Bottom-to-Top, PivotDiagram ▶️ Layout Direction ▶️ Left-to-Right, or PivotDiagram ▶️ Layout Direction ▶️ Right-to-Left from the Visio PivotDiagram menu. Note that this is just a bit Counter Intuitive... Top-to-Bottom is a horizontal orientation, whereas Left-to-Right is a Vertical orientation.

**ADDING GRAPHICS TO NODES AND NODE TIERS**

The default Pivot Diagram Visualization is shown as White Boxes with a Blue Header. However, this may be changed on-the-fly to suit your needs. Visio contains two hidden Stencils; Departments, and Workflow Objects. These Stencils contain numerous SmartShape symbols which may be applied to any
Node to alter the look of that particular Node. Additionally the change of Node visualization can be based on ANY open stencil as well as the two hidden Stencils.

To change the appearance of any Node, simply Right-Click on the Node, choose “Apply Shape...” from the Context Menu, and select the desired SmartShape Master. When your selection is complete, Left-Click the OK Command Button to accept your choice, close the dialog, and apply your choice.

REVERSE-ENGINEERING ODBC DATA SOURCES FOR DOCUMENTATION

In previous Versions and Editions of Visio there existed a tool which would allow you to Reverse-Engineer an ODBC-compliant Data Source, make changes to the Schema, and publish those changes back to the Data Source to physically update the Data Source. Under Visio 2007 Professional this has changed. The focus and the implementation are now to Reverse-Engineer to DOCUMENT the Schema of an ODBC-compliant Data Source.

To begin this process under Visio 2007, choose File ➤ New ➤ Software and Database ➤ Database Model Diagram from the Visio File Menu. This action will create a new blank Database Model Diagram. Under Visio 2010, go to the Backstage area, from the Template Categories, go to Software and Database. Select the Database Model Diagram item. Choose the desired units and then Left-click on the Create Item.

With Visio 2007 Choose Database ➤ Reverse Engineer... from the Visio Database menu. With Visio 2010 on the Database Tab of the Ribbon, in the Model Area, select the Reverse Engineer item. This action will display the Reverse Engineer Wizard.

The First Screen of the Reverse Engineer Wizard asks you to select (1) the Data Source from the Data Sources listing, and (2) the Installed Visio Drivers from the list of available drivers. NOTE: Ensure that the proper driver is selected for the desired data source. In other words, if you are choosing a Microsoft Office Access Database, then ensure that you have chosen the Microsoft Access driver as well. Incompatible driver to data source matches result in less than optimal results. When you have properly chosen the data source and the driver, Left-Click the Next > Command Button to advance to the Second Screen of the Reverse Engineer Wizard.

The Visio Reverse Engineer Wizard respects all Passwords, Permissions, and Log-On’s. Therefore a small Connect Data Source / Log In dialog displays next. If credentials are necessary, enter them here. If not leave them blank. In either case, when complete, Left-Click the OK Command Button to enter the Data Source Selection Dialog of the Reverse Engineer Wizard.

A Windows File Dialog will display next. This will allow you to browse to, and select, the desired actual data source file. When you have the desired Data Source file selected, Left-Click the OK Command Button to advance to the Second Screen of the Reverse Engineer Wizard.

The Second Screen of the Reverse Engineer Wizard asks you to Check or Un-Check the items that you want to have included as part of the Reverse Engineer process. Note that if any of the items are grayed out, it is because that particular data source does not support them. When your choices have been made, Left-Click the OK Command Button to advance to the Third Screen of the Reverse Engineer Wizard.

The Third Screen of the Reverse Engineer Wizard asks you to check or un-check the Tables and Views (Queries) that you wish to include in the Reverse Engineer. When your choices have been made, Left-Click the OK Command Button to advance to the Fourth Screen of the Reverse Engineer Wizard.
The Fourth Screen of the Reverse Engineer Wizard asks you if you want the Reverse Engineered Items automatically added to the diagram or not. If you wish to see ALL of the selected Tables and Views, choose the Radio Button reading “Yes, add the shapes to the current page.”, if not, choose the Radio Button reading “No, I will add the shapes later.”. When your choices have been made, Left-Click the OK Command Button to advance to the Fifth Screen of the Reverse Engineer Wizard.

The Fifth (and Final) Screen of the Reverse Engineer Wizard provides a summary of the Tables and Catalog Information that will be included in the Reverse Engineer. If all is correct, Left-Click the Finish Command Button to advance to confirm your choices, close the Wizard and generate the Reverse Engineered Data Source Diagram.

At the bottom of the Visio Diagram Area is a docked Window. This Window has two tabs: an Output tab, which provides information on what was reverse engineered and how long it took to accomplish the task, and a Database Properties Tab. This Tab, when a database object is selected, provides feedback about the reverse engineered object. Note that Views (Queries) are shown in the diagram in Gray and Tables are shown in White. Left-Click, to select, an object and then scroll through the properties for that object. Fill in the Notes / Comments area for each object to fully document the Reverse Engineered Data Source.

**NETWORK DIAGRAMMING**

**LOGICAL NETWORK DIAGRAMMING**

To begin a new Logical Network Diagram under Visio 2007, choose File ➤ New ➤ Network ➤ Detailed Network Diagram from the Visio File menu. With Visio 2010, go to the Backstage view and choose the Network Template Category and select the Detailed Network Diagram item. Choose the units desired and Left-click on the Create Item.

**ETHERNET BACKBONE SmartShape symbols**

As part of the collection of SmartShape symbols found on the Network and Peripherals Stencil as part of the Detailed Network Diagram Solution in Visio, one of the most often used Master SmartShape symbols is the Ethernet SmartShape symbol.

Note that this SmartShape symbol, when selected, has seven Control Handles (little yellow diamonds) shown on the SmartShape symbol. If you float your cursor over any of these control handles a small tool tip appears stating “Connect To Network Device”. Left-Clicking and dragging this control handle onto a connection point on any network SmartShape symbol, glues this branch of the Ethernet backbone to that item of Network Equipment.

Notice that there are Five Control Handles shown already positioned off the backbone itself. Note that there are apparently two Control Handles lying on the body of the Backbone. Each of these two Control Handles is actually a stack of 28 Control Handles. This means that each of the Backbone SmartShape symbols has a total of Sixty-Four available connections. These backbones may be glued together to make even longer backbones with even more connections.

**SERVER SmartShape symbols**

When creating a Visio Detailed Network Diagram you will note that a Visio Stencil is opened titled “Servers”. This Stencil has 16 individual Server Master SmartShape symbols. All 16 of these Master SmartShape symbols are identical with the exception that each of them have a small icon affixed to the Lower-Right-Hand-Corner of the SmartShape symbol. These icons are designed to visually differentiate the types of servers available to the Diagram. In addition to a generic Server are included : File Server E-
mail Server, E-commerce Server, Database Server, Proxy Server, Real-time communication Server, Content management Server, FTP Server, Streaming media Server, Web Server, Management Server, Directory Server, Print Server, Mobile information Server, and Application Server. This is done so that even at a distance, in a presentation, the purpose and use of the servers is quite apparent.

**PHYSICAL NETWORK DIAGRAMMING**

**RACK DIAGRAMS**

To create a new Rack Diagram under Visio 2007, choose File ▶ New ▶ Network ▶ Rack Diagram from the Visio File menu. With Visio 2010, go to the Backstage view and choose the Network Template Category and select the Rack Diagram item. Choose the units desired and Left-click on the Create Item.

When the Rack Diagram has been initialized at creation, you will be confronted with the typical Visio environment: Stencils on the Left, Diagram Surface on the Right. You will note that on the Rack-mounted Equipment Stencil, there are both Rack and Cabinet Master SmartShape symbols. These SmartShapes may be resized in Height to accommodate anywhere between 1 U and 56 U height and still fit on a given Visio Diagram Page. Adjust the height to suit the particular Rack or Cabinet you are trying to represent. Note also that both the Rack and Cabinet SmartShape symbols are 2-D Symbols with connection points displayed at each and every U mounting point. All of the included Rack-mounted generic pieces of equipment are 1-D SmartShape symbols, designed to very nicely Snap and Glue to the Connection Points on the Rack and/or Cabinet.

**SEARCHING FOR ADDITIONAL NETWORK SmartShape symbol CONTENT**

Keep in mind that the Rack-mounted equipment SmartShape symbols are, by nature, and by design, quite generic. They are meant to illustrate generic Servers, Routers, Switches, Patch Panels, etc.

If you need a specific item of equipment that looks EXACTLY like, and contains all of the properties of specific equipment, you are heartily encouraged to browse to the Manufacturer’s Web Site and search for Visio Stencils containing all of their equipment items, designed to encourage you to specify their equipment.

Use the search engine of your choice. You will find a wealth of free content available.

Additionally go to the [http://VisioToolbox.com](http://VisioToolbox.com) web site to read about third-party content providers for Network Equipment SmartShape symbols on Visio Stencils.

**OTHER NOTABLE ADVANCED (2007 PROFESSIONAL AND 2010 PROFESSIONAL AND PREMIUM EDITIONS) DIAGRAM TYPES**

The Available Microsoft Office Visio 2007 Professional Edition Diagram Types / Solutions include every Diagram type included in the Standard Edition as well as:

- ITIL Diagram
- Pivot Diagram (*covered in this Guide*)
- Value Stream Map
- Basic Electrical Diagram
- Circuits and Logic Diagram
- Fluid Power Diagram
- Industrial Control Systems Diagram
- Part and Assembly Diagram
- Piping and Instrumentation (P&ID) Diagram
- Process Flow Diagram
- Systems Diagram
- IDEF0 Diagram
- SDL Diagram
- Electrical and Telecom Plan Diagram
• Floor Plan Diagram (covered in this Guide)
• Home Plan Diagram
• HVAC Control Logic Diagram
• HVAC Plan Diagram
• Plant Layout Diagram
• Plumbing and Piping Layout Diagram
• Reflected Ceiling Plan Layout Diagram
• Security and Access Plan Diagram
• Site Plan Diagram
• Space Plan Diagram
• Active Directory Diagram
• Conceptual Web Site Diagram
• Detailed Network Diagram (covered in this Guide)
• UML Model Diagram

SharePoint Workflow Diagram
Wireframe Diagram
LDAP Directory
BPMN Diagram
Six Sigma Diagram
Value Stream Map

• LDAP Directory Diagram
• Rack Diagram (covered in this Guide)
• Website Map Diagram
• COM and OLE Diagrams
• Database Model Diagram (covered in this Guide)
• Data Flow Model Diagram
• Enterprise Application Diagram
• Express-G Diagram
• Jackson Diagram
• ORM Diagram
• Program Structure Diagram
• ROOM Diagram
• Windows XP User Interface Diagram

Menu Shortcuts

File

New » New Drawing : (Ctrl+N) or (Alt+F, N, N)
Open... : (Ctrl+O) or (Alt+F, O)
Save : (Ctrl+S) or (Alt+F, S)
Save As... : (Alt_F, A) or (F12)
Save as Web Page... : (Alt+F, G)
Publish as PDF or XPS... : (Alt+F, B)
Remove Hidden Information... : (Alt+F, R)

Shapes » My Shapes » Organize My Shapes : (Alt+F, M, O)
Shapes » Open Stencil... : (Alt+F, E, O)
Shapes » New Stencil (US Units) : (Alt+F, S, N)
Shapes » New Stencil (Metric) : (Alt+F, S, E)
Shapes » Show Document Stencil : (Alt+F, S, D)
Page Setup... : (Alt+F, U)
Print Preview : (Ctrl+F2) or (Alt+F, V)
Print... : (Ctrl+P) or (Alt+F, P)
Send To » Mail Recipient (as Attachment)... : (Alt+F, D, M)
Send To » Routing Recipient... : (Alt+F, D, R)
Send To » Exchange Folder... : (Alt+F, D, E)
Properties : (Alt+F, I)
Exit : (Alt+F, X)

Edit

Undo : (Ctrl+Z) or (Alt+E, U)
Redo : (Ctrl+Y) or (Alt+E, R)
Cut : (Ctrl+X) or (Alt+E, T)
Copy : (Ctrl+C) or (Alt+E, C) [with selection]
Copy Drawing : (Ctrl+C) or (Alt+E, C) [nothing selected]
Paste : (Ctrl+V) or (Alt+E, P)
Paste Special... : (Ctrl+Alt+V) or (Alt+E, S)
Paste as Hyperlink : (Alt+E, H)
Clear: (Del) or (Alt+E, A)
Select All: (Ctrl+A) or (Alt+E, L)
Select by Type…: (Alt+E, B)
Duplicate: (Ctrl+D) or (Alt+E, I)
Delete Pages…: (Alt+E, D)
Find…: (Ctrl+F) or (Alt+E, F)
Replace…: (Alt+E, E)
Reconvert: (Alt+E, V)

Go To ▶ Foreground: (Alt+E, G, F)
Go To ▶ Background: (Alt+E, G, B)
Go To ▶ Page…: (Alt+E, G, P)

Links: (Alt+E, K)
Object: (Alt+E, O)

View ▶

Shapes Window: (Alt+V, N)
Pan & Zoom Window: (Alt+V, P)
Shape Data Window: (Alt+V, E)
Size & Position Window: (Alt+V, S)
Drawing Explorer Window: (Alt+V, D)
External Data Window: (Alt+V, X)
Task Pane: (Ctrl+F1) or (Alt+V, K)
Rulers: (Alt+V, R)
Grid: (Alt+V, G)
Guides: (Alt+V, U)
Connection Points: (Alt+V, C)
Page Breaks: (Alt+V, B)
Header and Footer…: (Alt+V, H)
Markup: (Alt+V, A)
Layer Properties…: (Alt+V, L)
Full Screen: (F5) or (Alt+V, F)

Zoom ▶ Last Zoom: (Alt+V, Z, L)
Zoom ▶ Page Width: (Alt+V, Z, P)
Zoom ▶ Whole Page: Ctrl+W or (Alt+V, Z, W) [Visio 2007 and Prior]
Zoom  ▪ Whole Page : Ctrl+Shift+W or (Alt+V, Z, W) [Visio 2010]
Zoom  ▪ 400% : (Alt+V, Z, 4)
Zoom  ▪ 200% : (Alt+V, Z, 2)
Zoom  ▪ 150% : (Alt+V, Z, 0)
Zoom  ▪ 100% : (Ctrl+Shift+I) or (Alt+V, Z, 1)
Zoom  ▪ 75% : (Alt+V, Z, 7)
Zoom  ▪ 50% : (Alt+V, Z, 5)
Zoom  ▪ Zoom... : (Alt+V, Z, Z)

Insert ▪
New Page... : (Alt+I, N)
Field : (Alt+I, F)
Symbol... : (Alt+I, S)
Shape Screen Tip... : (Alt+I, T)
Comment : (Alt+I, M)
Picture  ▪ Clip Art... : (Alt+I, P, C)
Picture  ▪ From File... : (Alt+I, P, F)
Picture  ▪ Chart : (Alt+I, P, H)
Picture  ▪ Equation... : (Alt+I, P, E)
Text Box : (Alt+I, X)
CAD Drawing... : (Alt+I, D)
Control... : (Alt+I, C)
Object... : (Alt+I, O)
Hyperlinks... : (Ctrl+K) or (Alt+I, H)

Format ▪
Text... : (F11) or (Alt+O, T)
Line... : (Shift+F3) or (Alt+O, L)
Fill... : (F3) or (Alt+O, F)
Shadow... : (Alt+O, W)
Corner Rounding... : (Alt+O, C)
Theme... : (Alt+O, M)
Picture... : (Alt+O, I)
Ink... : (Alt+O, I)
Protection... : (Alt+O, P)
Behavior... : (Alt+O, B)
Special... : (Alt+O, E)
Style... : (Alt+O, S)
Define Style... : (Alt+O, D)
Layer... : (Alt+O, R)

**Tools**

Spelling  ▶ Spelling... : (F7) or (Alt+T, S, S)
Spelling  ▶ Spelling Options... : (Alt+T, S, O)
Research... : (Alt+T< H)
Document Management... : (Alt+T, U)
Track Markup : (Alt+T, K)
Snap & Glue... : (Alt+T, G)
Ruler & Grid... : (Alt+T, R)
Color Palette... : (Alt+T, P)
Macro  ▶ Macros... : (Alt+F8) or (Alt+T, M, M)
Macro  ▶ Record New Macro... : (Alt+T, M, R)
Macro  ▶ Visual Basic Editor : (Alt+F11) or (Alt+T, M, V)
Add-Ons  ▶ Run Add-On... : (Alt+T,
Add-Ons  ▶ Business ▶ Organization Chart Wizard : (Alt+T, D, B, W)
Add-Ons  ▶ Maps and Floor Plans ▶ Color by Values... : (Alt+T, D, M, C)
Add-Ons  ▶ Maps and Floor Plans ▶ Disable Space Plan : (Alt+T, D, M, D)
Add-Ons  ▶ Maps and Floor Plans ▶ Enable Space Plan : (Alt+T, D, M, E)
Add-Ons  ▶ Maps and Floor Plans ▶ Import Data... : (Alt+T, D, M, I)
Add-Ons  ▶ Maps and Floor Plans ▶ Label Shapes... : (Alt+T, D, M, L)
Add-Ons  ▶ Maps and Floor Plans ▶ Refresh Data : (Alt+T, D, M, R)
Add-Ons  ▶ Visio Extras ▶ Move Shapes... : (Alt+T, D, V, M)
Add-Ons  ▶ Visio Extras ▶ Number Shapes... : (Alt+T, D, V, N)
Add-Ons  ▶ Visio Extras ▶ Array Shapes... : (Alt+T, D, V, Y)
Add-Ons  ▶ Visio Extras ▶ Convert CAD Drawings... : (Alt+T, D, V, D)
Add-Ons  ▶ Visio Extras ▶ Convert CAD Library... : (Alt+T, D, V, L)
Add-Ons  ▶ Visio Extras ▶ Data Export Wizard : (Alt+T, D, V, E)
Add-Ons  ▶ Visio Extras ▶ Database Refresh : (Alt+T, D, V, R)
Add-Ons  ▶ Visio Extras ▶ Database Settings... : (Alt+T, D, V, S)
Add-Ons ▶ Visio Extras ▶ Database Update : (Alt+T, D, V, U)
Add-Ons ▶ Visio Extras ▶ Database Wizard : (Alt+T, D, V, W)
Add-Ons ▶ Visio Extras ▶ Export to Database… : (Alt+T, D, V, X)
Add-Ons ▶ Visio Extras ▶ Link to ODBC Database… : (Alt+T, D, V, T)
Add-Ons ▶ Visio Extras ▶ Shape Area and Perimeter… : (Alt+T, D, V, H)
Auto Correct Options… : (Alt+T, A)
Trust Center… : (Alt+T, T)
Customize… : (Alt+T, C)
Options… : (Alt+T, O)

Data ▶
Shape Data… : (Alt+D, S)
Link Data to Shapes… : (Alt+D, L)
Automatically Link… : (Alt+D, A)
Refresh Data… : (Alt+D, R)
Display Data on Shapes… : (Alt+D, D)
Insert PivotDiagram… : (Alt+D, P)
Insert Data Solutions ▶ Organization Chart… : (Alt+D, N, O)
Insert Data Solutions ▶ Timeline… : (Alt+D, N, T)
Insert Data Solutions ▶ Calendar… : (Alt+D, N, C)
Insert Data Solutions ▶ Gantt Chart… : (Alt+D, N, G)
Reports… : (Alt+D, T)

Shape ▶
Grouping ▶ Group : (Shift+Ctrl+G) or (Alt+S, G, G)
Grouping ▶ Ungroup : (Shift+Ctrl+U) or (Alt+S, G, U)
Grouping ▶ Add to Group : (Alt+S, G, A)
Grouping ▶ Remove from Group : (Alt+S, G, R)
Grouping ▶ Convert to Group : (Alt+S, G, R)
Order ▶ Bring to Front : (Alt+S, O, F)
Order ▶ Send to Back : (Alt+S, O, B)
Order ▶ Bring Forward : (Alt+S, O, O)
Order ▶ Send Backward : (Alt+S, O, A)
Rotate or Flip ▶ Rotate Left : (Ctrl+L) or (Alt+S, R, L)
Rotate or Flip ▶ Rotate Right : (Ctrl+R) or (Alt+S, R, R)
Rotate or Flip ➔ Rotate Text : (Alt+S, R, T)

Rotate or Flip ➔ Flip Horizontal : (Ctrl+H) or (Alt+S, R, H)

Rotate or Flip ➔ Flip Vertical : (Ctrl+J) or (Alt+S, R, V)

Operations ➔ Update Alignment Box : (Alt+S, N, A)

Operations ➔ Reverse Ends : (Alt+S, N, R)

Operations ➔ Union : (Alt+S, N, U)

Operations ➔ Combine : (Alt+S, N, C)

Operations ➔ Fragment : (Alt+S, N, F)

Operations ➔ Intersect : (Alt+S, N, I)

Operations ➔ Subtract : (Alt+S, N, S)

Operations ➔ Join : (Alt+S, N, J)

Operations ➔ Trim : (Alt+S, N, T)

Operations ➔ Offset... : (Alt+S, N, O)

Operations ➔ Fit Curve... : (Alt+S, N, E)

Align Shapes... : (Alt+S, A)

Distribute Shapes... : (Alt+S, D)

Connect Shapes : (Alt+S, C)

Configure Layout... : (Alt+S, L)

Re-layout Shapes : (Alt+S, E)

Center Drawing : (Alt+S, W)

Actions ➔ Properties : (Alt+S, T, R)

Window ➔

New Window : (Alt+W, N)

Tile : (Alt+W, T)

Cascade : (Alt+W, C)

Show ShapeSheet : (Alt+W, S)

Help ➔

Microsoft Office Visio Help : (Alt+H, H)

Developer Reference : (Alt+H, D)

Sample Diagrams : (Alt+H, S)

Microsoft Office Online : (Alt+H, M)

Contact Us : (Alt+H, C)

Check for Updates : (Alt+H, K)
Office Diagnostics... : (Alt+H, N)
Activate Product... : (Alt+H, V)
Privacy Options... : (Alt+H, P)
About Microsoft Office Visio... (Alt+H, A)

**SmartShape Symbol Context (Right-Click) Menu Shortcuts**

Cut : (Right-Click, T)
Copy : (Right-Click, C)
Paste : (Right-Click, P)
Format ▶ Text... : (Right-Click, O, T)
Format ▶ Line... : (Right-Click, O, L)
Format ▶ Fill... : (Right-Click, O, F)
Format ▶ Allow Themes : (Right-Click, O, A)
Format ▶ Remove Theme : (Right-Click, O, M)
Format ▶ Picture... : (Right-Click, O, U)
Format ▶ Ink... : (Right-Click, O, N)
Format ▶ Protection... : (Right-Click, O, P)
Format ▶ Behavior... : (Right-Click, O, B)
Format ▶ Special... : (Right-Click, O, E)
Format ▶ Style... : (Right-Click, O, S)
Format ▶ Layer... : (Right-Click, O, R)
Data ▶ Shape Data... : (Right-Click, D, S)
Data ▶ Edit Data Graphic... : (Right-Click, D, E)
Data ▶ Remove Data Graphic : (Right-Click, D, R)
Shape ▶ Group : (Right-Click, E, G)
Shape ▶ Ungroup : (Right-Click, E, U)
Shape ▶ Bring to Front : (Right-Click, E, F)
Shape ▶ Send to Back : (Right-Click, E, B)
Shape ▶ Bring Forward : (Right-Click, E, I)
Shape ▶ Send Backward : (Right-Click, E, S)
Shape ▶ Rotate Text : (Right-Click, E, T)
Shape ▶ Find Similar Shapes : (Right-Click, E, M)
Help : (Right-Click, H)
Properties : (Right-Click, R)
**Drawing Navigation Shortcuts**

Zoom In To an Area Defined By A Rectangular Area : (Ctrl+Shift+Left-Click, Hold, Drag, Release)

Zoom In Incrementally : (Ctrl+Shift+Left-Click[tap])

Zoom Out Incrementally : (Ctrl+Shift+Right-Click[tap])

Zoom to the Whole Page : (Ctrl+W)

Zoom to 100% : (Ctrl+Shift+I)

Pan at the Current Zoom Ratio : (Ctrl+Shift+Right-Click, Hold, Drag)

**Drawing and Selection Tools Shortcuts**

Pointer Tool : (Ctrl+1)

Text Tool : (Ctrl+2)

Connector Tool : (Ctrl+3)

Pencil Tool : (Ctrl+4)

Freeform Tool : (Ctrl+5)

Line Tool : (Ctrl+6)

Arc Tool : (Ctrl+7)

Rectangle Tool : (Ctrl+8)

Ellipse Tool : (Ctrl+9)

Connection Point Tool : (Ctrl+Shift+1)

Crop Tool : (Ctrl+Shift+2)

Stamp Tool : (Ctrl+Shift+3)

Text Block Tool : (Ctrl+Shift+4)

Format Painter Tool : (Ctrl+Shift+P)

**Text Formatting Shortcuts**

Toggle BOLD for Text Block or Selected Text : (Ctrl+B)

Toggle ITALIC for Text Block or Selected Text : (Ctrl+I)

Toggle UNDERLINE for Text Block or Selected Text : (Ctrl+U)

Toggle DOUBLE UNDERLINE for Text Block or Selected Text : (Ctrl+Shift+D)

Toggle ALL CAPS for Text Block or Selected Text : (Ctrl+Shift+A)

Toggle SMALL CAPS for Text Block or Selected Text : (Ctrl+Shift+K)

Toggle SUBSCRIPT for Text Block or Selected Text : (Ctrl+=)

Toggle SUPERSCRIPT for Text Block or Selected Text : (Ctrl+Shift+=)

Increase Font Size for Text Block or Selected Text : (Ctrl+Shift+>)
Decrease Font Size for Text Block or Selected Text : (Ctrl+Shift+<)
Align Text in Text Block LEFT JUSTIFIED : (Ctrl+Shift+L)
Align Text in Text Block CENTER JUSTIFIED : (Ctrl+Shift+C)
Align Text in Text Block RIGHT JUSTIFIED : (Ctrl+Shift+R)
Align Text in Text Block FULL HORIZONTAL JUSTIFICATION : (Ctrl+Shift+J)
Align Text in Text Block TOP JUSTIFIED : (Ctrl+Shift+T)
Align Text in Text Block MIDDLE JUSTIFIED : (Ctrl+Shift+M)
Align Text in Text Block BOTTOM JUSTIFIED : (Ctrl+Shift+V)

**Text Editing Keyboard Shortcuts**

Move to the Previous Character in the Text [Cursor at a specific character] : (Left Arrow)
Move to the Next Character in the Text [Cursor at a specific character] : (Right Arrow)
Move to the Line Above in the Text [Cursor at a specific character] : (Up Arrow)
Move to the Line Below in the Text [Cursor at a specific character] : (Down Arrow)
Move to the Previous Word in the Text [Cursor at a specific character] : (Ctrl+Left Arrow)
Move to the Next Word in the Text [Cursor at a specific character] : (Ctrl+Right Arrow)
Move to the Previous Paragraph in the Text [Cursor at a specific character] : (Ctrl+Up Arrow)
Move to the Next Paragraph in the Text [Cursor at a specific character] : (Ctrl+Down Arrow)
Select All Text in the Text Block : (Ctrl+A)
Select the Previous Character in the Text [Cursor at a specific character] : (Shift+Left Arrow)
Select the Next Character in the Text [Cursor at a specific character] : (Shift+Right Arrow)
Select the Previous Word in the Text [Cursor at a specific character] : (Ctrl+Shift+Left Arrow)
Select the Next Word in the Text [Cursor at a specific character] : (Ctrl+Shift+Right Arrow)
Select the Previous Line in the Text [Cursor at a specific character] : (Shift+Up Arrow)
Select the Next Line in the Text [Cursor at a specific character] : (Shift+Down Arrow)
Select the Previous Paragraph in the Text [Cursor at a specific character] : (Ctrl+Shift+Up Arrow)
Select the Next Paragraph in the Text [Cursor at a specific character] : (Ctrl+Shift+Down Arrow)
Delete the Previous Word in the Text Block [Cursor at a specific character] : (Ctrl+Backspace)

**Shape Management Keyboard Shortcuts**

Bring Selected SmartShape symbol to the Front of all other SmartShape symbols : (Ctrl+Shift+F)
Send Selected SmartShape symbol to the Back of all other SmartShape symbols : (Ctrl+Shift+B)
Flip Selected SmartShape symbol Horizontally : (Ctrl+H)
Flip Selected SmartShape symbol Vertically : (Ctrl+J)
Rotate Selected SmartShape symbol Left : (Ctrl+L)
Rotate Selected SmartShape symbol Right: (Ctrl+R)
Group Selected SmartShape Symbols : (Ctrl+Shift+G)
Ungroup Selected SmartShape Symbols : (Ctrl+Shift+U)
Move the focus from one selected SmartShape symbol to the next SmartShape symbol on the drawing page : (Tab)
Move the focus from one selected SmartShape symbol to the next SmartShape symbol on the drawing page in reverse order : (Shift+Tab)
Select a SmartShape symbol that has the focus : (Enter)
Clear the selection or focus of any and/or all SmartShape symbols on the drawing page : (Esc)
Switch between Text Edit mode and Shape Selection mode on a selected SmartShape symbol : (F2)
Nudge a selected SmartShape symbol or selected SmartShape symbols to the Left : (Left Arrow)
Nudge a selected SmartShape symbol or selected SmartShape symbols to the Right : (Right Arrow)
Nudge a selected SmartShape symbol or selected SmartShape symbols Upward : (Up Arrow)
Nudge a selected SmartShape symbol or selected SmartShape symbols Downward : (Down Arrow)
Nudge a selected SmartShape symbol or selected SmartShape symbols to the Left one pixel at a time : (Shift+Left Arrow)
Nudge a selected SmartShape symbol or selected SmartShape symbols to the Right one pixel at a time: (Shift+Right Arrow)
Nudge a selected SmartShape symbol or selected SmartShape symbols Upward one pixel at a time: (Shift+Up Arrow)
Nudge a selected SmartShape symbol or selected SmartShape symbols Downward one pixel at a time: (Shift+Down Arrow)
Appendix 2 – The Complete Visio 2007 Professional Edition Toolbars

To accessing the collection of Toolbars, Right-Click on any open space in the Toolbar area and Check and Uncheck the Toolbars that you would like to have available.

The Toolbar Collection

Note that many of the Toolbars include “swappable” Toolbar items. Hidden under many items are additional items. To access these “swappable” items, look immediately to the Right of the Toolbar item and find a very small down-pointing triangle (▼), click on that triangle, and select the alternate Toolbar item.

Standard
The Standard Toolbar contains the most generally used commands while working in the Visio environment. These include file management (opening, and saving Visio diagrams, beginning new Visio diagrams, and printing diagrams) as well as editing tools, the Pointer Tool, the Dynamic Connector Tool, the Text Tool, the AutoConnect Tool and Zoom Percentage List.

Formatting
The Format Shape Toolbar contains commands for setting a SmartShape symbol’s font and font size, setting text properties such as Bolding, Italics, Underlining, Text Justification, Bullets, Text, Line and Fill colors, applying Themes, Line Weight, Line Type, and Line Ends.

Action
The Action Toolbar contains tools for flipping and rotating SmartShape symbols, for Aligning, laying out, and distributing SmartShape symbols, for Grouping and Ungrouping SmartShape symbols, and accessing the Shape Data (Custom Properties) of SmartShape symbols.

Data
The Data Toolbar provides access to commands for working with the new Visio 2007 Professional Data Connectivity tools. Included in these are the Shape Data Dialog, the Link Data to Shapes Wizard, the Automatically Link Wizard, the Refresh All command and the Data Graphics Task Pane.
Developer
The Developer Toolbar is utilized when working with both ShapeSheets and Automation Controllers like Visual Basic for Applications. Macro Recording, Running and the VBA IDE, Inserting ActiveX Controls, the Show ShapeSheet (Alt+F11) command, and the toggle between Run Mode and Design Mode are available on this Toolbar.

Drawing
The Drawing Toolbar provides access to the varied Visio basic drawing tools. Included in these are the Rectangle Tool, the Ellipse Tool, the Line Tool, the Elliptical Arc Tool, the Freeform Tool, and the Pencil Tool.

Format Shape
The Format Shape Toolbar contains readily accessible commands including those for associating a layer with a SmartShape, corner rounding, transparency, shadow settings and more.

Format Text
The Format Text Toolbar includes access to additional Text Formatting commands such as increasing or decreasing the font size, setting strikethrough, Small Caps, Superscript, Subscript, Top, Middle and Bottom Text Block alignment, and increasing and decreasing the vertical spacing between paragraphs.

Ink
The Ink Toolbar is primarily designed for Tablet PC users, however some of the Ink Tools can be useful to any Visio user. In particular, the highlighting pen tool is wonderful for marking up Visio diagrams.

Layout & Routing
The Layout & Routing Toolbar displays commands for working with Dynamic Connector SmartShape symbols and the SmartShape symbols that are impacted by the connectors. The commands include appearance tools for Dynamic Connectors and routing behavior settings.
**Picture**

The Picture Toolbar is, as would be expected, applicable to working with imported images such as .JPG and .GIF images. Tool provided include an Insert Picture Tool, a cropping tool, an Image Rotation Tool, line weight, formatting and transparency tools.

**Reviewing**

The Reviewing Toolbar provides access to the set of tools applicable to mark-ups and team collaboration with Visio diagrams. These tools will activate the Reviewing Task Pane and provide comment and red-lining capabilities.

**Snap & Glue**

The Snap & Glue Toolbar contains a series of toggles which control the types of entities which can be snapped to and glued to.

**Stencil**

The Stencil Toolbar includes commands for working with Stencils in the Shapes Pane. These tools allow for ease of access to opening stencils, docking and floating stencils, creating new stencils, and the display style of the icons on stencils.

**Task Pane**

The Task Pane Toolbar is actually a small misnomer. It actually displays the Visio Task Pane (normally displayed at the Right edge of the Visio environment and sized to the full height of the Visio Diagramming Window. Because the Task Pane is an independent window, it can be relocated, and resized to suit the user’s needs. The contents of the Task Pane are automatically filled based on the context of the required task. The Task Pane can have the contents supplied by selecting the small down-pointing triangle (▼) on the Task Pane’s Title bar. The available contents modes are:

- Theme Colors
- Theme Effects
The View Toolbar contains toggles controlling the visibility of items such as Rulers, The Grid, Guides, Connection Points, and Page Breaks. It also provides access to some of the floatable / dockable windows including The Shapes Window, Pan and Zoom Window, Shape Data Window, Size and Position Window, External Data Window, Drawing Explorer Window, Master Explorer Window, and the Layer Properties Window.

The Web Toolbar includes only three toolbar items: an Insert Hyperlink command, and Forward and Back Browse Navigation Control Buttons.

The Ribbon Tab Collection

What follows is a collection of all basic RibbonTabs within Visio 2010. Note that with each solution created, Visio may opt to add an additional Ribbon Tab for that particular Solution.

**File**

The File Tab toggles between the Backstage View and the Drawing Environment. It contains items to Save, Open, Close, and see Recently Used Diagrams as well as create new Diagrams. It also contains items to Print Diagrams, Send to SharePoint and is the new location for the Options Dialog (2010) replacing the older Tools Options Menu found in 2007.

**Home**

The Home Tab contains basic formatting and arranging items.

**Insert**

The Insert Tab contains items for inserting content into Visio diagrams as well as into text streams.
**Design**

The Design Tab contains items for managing Themes, Page Sizing and Orientation, inserting Backgrounds and Title Blocks, managing global connector configuration and relaying out SmartShape symbols on pages.

**Data**

The Data Tab contains all items for managing the new Visio 2007 / 2010 Data Connectivity as well as managing Data Graphics and Data Legends.

**Process**

The Process Tab contains items for creating Subprocesses, Validating Diagrams and working with SharePoint Workflows.

**Review**

The Review Tab contains items for Proofing (spell check etc.), Language Options, Comments, and Markup. It also is where you will need to go to create Custom Reports.
**View**

The View Tab contains all items for visual features of Visio such as Rulers, the Grid, Guides, and all Task Panes. It also contains Window Management items as well as the ability to run Macros and Add-ons.

---

**Developer (Only when Run in Developer Mode is Enabled)**

The Developer Tab collects all of the tools necessary to create SmartShape symbols, VBA Macros, Add-Ins created from VB6, VB.NET, C++, and C#.NET. It also contains tools for creating and managing Custom Stencils as well as accessing the Drawing Explorer.

---

**Appendix 4 – The Complete Visio 2007 / 2010 File Type Compendium**

**The Differences and Similarities between the VSD, VST, and VSS File Formats**

Visio actually utilizes a singular file format natively to access, retrieve, store, and display Visio diagrams. However, the file extension tells Visio how the file should be handled. To explain further:

When Visio finds a Visio file with the extension .VSD (Visio Document/Drawing/Diagram), Visio opens the file in drawing mode: that is, it opens the file in a standard diagram window with the associated stencils open in the Shapes Pane to the Left of the diagram window.

When Visio finds a Visio file with the extension .VST (Visio Document Template), Visio reads the file into memory and then creates a NEW Visio Document (.VSD) based on that Template as an exact copy of that Template file.

When Visio finds a Visio file with the extension of .VSS (Visio Stencil), Visio opens the file in Stencil mode: that is, it opens the file in the Shapes Pane at the left of the Visio environment and displays each Master SmartShape symbol which resides on the file’s Local Document Stencil as an Icon Image representing the Master SmartShape symbol.

Every Visio Drawing file has a Local Document Stencil. Every Visio Stencil has a Drawing Page. It is the file extension that informs Visio how the file should be handled.

A Visio Template is a Visio Drawing file AND references to all of the associated Visio Stencil files saved as a workspace. This saved workspace is the basis from which new Visio Drawings are created. These new Visio drawings are clones of the original Drawing and Drawing environment from which the workspace was saved.

**The Catalog of Visio File Formats**

<table>
<thead>
<tr>
<th>Visio File Extension</th>
<th>Visio File Type</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Extension</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>-------------</td>
</tr>
<tr>
<td>.VSD</td>
<td>Visio Drawing / Diagram / Document File</td>
</tr>
<tr>
<td>.VDW</td>
<td>Visio Drawing for the Web (SharePoint Export Format)</td>
</tr>
<tr>
<td>.VSS</td>
<td>Visio Stencil File</td>
</tr>
<tr>
<td>.VST</td>
<td>Visio Template File (with saved Workspace)</td>
</tr>
<tr>
<td>.VDX</td>
<td>Visio XML Drawing File</td>
</tr>
<tr>
<td>.VSX</td>
<td>Visio XML Stencil File</td>
</tr>
<tr>
<td>.VTX</td>
<td>Visio XML Template File</td>
</tr>
<tr>
<td>.VSW</td>
<td>Visio Workspace File (obsolete)</td>
</tr>
<tr>
<td>.VSU</td>
<td>Visio Saved User Interface (Menus, Toolbars, Accelerators) File</td>
</tr>
<tr>
<td>.SVG</td>
<td>Scalable Vector Graphics File (export)</td>
</tr>
<tr>
<td>.PCZ</td>
<td>Compressed Macintosh PICT (import export)</td>
</tr>
<tr>
<td>.EMZ</td>
<td>Compressed Enhanced Metafile (import export)</td>
</tr>
<tr>
<td>.WMZ</td>
<td>Compressed Windows Metafile (import export)</td>
</tr>
<tr>
<td>.CGM</td>
<td>Computer Graphics Metafile (import export)</td>
</tr>
<tr>
<td>.CDR</td>
<td>Corel Draw (import)</td>
</tr>
<tr>
<td>.EPS</td>
<td>Encapsulated Postscript (import)</td>
</tr>
<tr>
<td>.GIF ; .GFA</td>
<td>Graphics Interchange Format (import)</td>
</tr>
<tr>
<td>.PCT ; .PCIT</td>
<td>Macintosh PICT (import export)</td>
</tr>
<tr>
<td>.EMF</td>
<td>Windows Enhanced Metafile (import export)</td>
</tr>
<tr>
<td>.WMF</td>
<td>Windows Metafile (import export)</td>
</tr>
<tr>
<td>.WPG</td>
<td>WordPerfect Graphics (import)</td>
</tr>
<tr>
<td>.PNG</td>
<td>Portable Network Graphics (import)</td>
</tr>
<tr>
<td>.TIF ; .TIFF</td>
<td>Tagged Image File Format (import)</td>
</tr>
<tr>
<td>.BMP ; .dib ; .RLE ; .BMZ</td>
<td>Windows Bitmap (import)</td>
</tr>
<tr>
<td>.DWG</td>
<td>AutoCAD Drawing (import export)</td>
</tr>
<tr>
<td>.DXF</td>
<td>Drawing Interchange Format (import export)</td>
</tr>
<tr>
<td>.HTM ; .HTML</td>
<td>Web Page (export)</td>
</tr>
<tr>
<td>.PDF</td>
<td>Portable Document Format (export)</td>
</tr>
</tbody>
</table>